0

I have had a working dual booting fedora (23) and Windows 10 system (for quite a while).

I was tinkering with an old computer and was using the above system to update a 32 bit Ubuntu system on a USB drive before using it on the older system, and Ubuntu asked to update its grub loader, so I said yes.

I had the option to "install grub" on each of the hard drives (the USB & the native HDD on the dual boot system), but I only installed it on the USB drive.

Now, I can still get the dual boot system to boot, but I HAVE to have the USB drive connected. I have tried a few fixes including "boot-repair" and "grub-update", but still no joy.

Any suggestions? Grub and bootloader documentation online seems to be spotty and obscure at best.

0

Eject your Bootable Flash drive and insert GParted CD, check which of the devices/partitions have got the boot flag on, if it's other than your native HDD(which it used to/should be), revert & save it(don't let the flash be bootable) and try rebooting. Your HDD has already got the grub, it could just be pointing through the flash as while updating you chose it. If the issue persists, plug the flash back in and install it on both.

this could be of some use.

  • I tried the above (unplugged the external (booting) drive) and used GParted to make sure that the first partition on the native HDD is, and that just dumps me into grub rescue where I'm lost. I just ran boot-repair from the Ubuntu USB drive, and I got the following boot results: paste.ubuntu.com/18752121 – bbneo Jul 8 '16 at 1:59

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.