1

I am running Debian 8 with the 3.16 kernel on an eeePC 1001P. I have a fair bit of Linux experience but unfortunately this one has me and my google-fu at a loss.

Initially almost everything worked out of the box, except brightness control was random and my fan was always running. I tracked the brightness issue to the presence of acpi_video0 in /sys/class/backlight causing X11 to prefer that over intel_backlight (which actually contols my backlight properly). I solved this by editing my xorg.conf.

Installing lm-sensors then showed only 2 sensors, both reading temperature. Booting with acpi_osi=Linux gains me fan control, and while I can still control my brightness via the slider in the Settings app, my brightness keys are dead.

1 Answer 1

0

I fixed this by installing acpid (sudo apt-get install acpid).

I then created 2 files:

/etc/acpi/events/asus-brightness:

event=hotkey ASUS010:00 0000002[0-9a-f]
action=/etc/acpi/brightness.sh %e

/etc/acpi/brightness.sh:

#!/bin/bash

test -f /usr/share/acpi-support/key-constants || exit 0
export DISPLAY=:0
PREV=$(cat /etc/acpi/prevbrightness)

if [[ "0x$3" -eq "0x20" || "0x$3" -lt "0x$PREV" ]] ; then
   xdotool key XF86MonBrightnessDown
elif [[ "0x$3" -eq "0x2F" || "0x$3" -gt "0x$PREV" ]] ; then
   xdotool key XF86MonBrightnessUp
else
   echo >&2 Unknown argument $1
fi

echo $3 > /etc/acpi/prevbrightness

Now, I ran echo 00000020 > /etc/acpi/prevbrightness as root (sudo su first)

Brightness controls now work!

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .