So I am running archlinux. On java -version my output is:

java version "1.7.0_101"
OpenJDK Runtime Environment (IcedTea 2.6.6) (Arch Linux build 7.u101_2.6.6-1-x86_64)
OpenJDK 64-Bit Server VM (build 24.95-b01, mixed mode)

I have installed with pacman the eclipse-java package. When I start eclipse I am getting the following error and eclipse crushes. enter image description here

How to pass this and run eclipse?


Eclipse now requires Java 8 and you're using Java 1.7, this won't work. Install jdk8-openjdk instead and/or wait for the bug in Arch Linux' bug tracker to be fixed.

  • Thank you Wieland. I have just set the java 1.8 and it is working smooth. For anyone who must do this, can use archlinux-java set java-8-openjdk – Cristian Jul 6 '16 at 16:40

FYI for Arch Linux users: Even though Arch Linux pacman gives the option to install jdk9-openjdk within the eclipse-common package (September 30, 2017), Eclipse Oxygen.1 (4.7.1) will not work with version 9. Install jdk8-openjdk instead. Use script "archlinux-java set java-8-openjdk" if another openjdk version is installed. Eclipse will work fine thereafter.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.