0

Thanks for taking a look...

I have a very old active OS, unfortunatly due to supplier issues I cannot upgrade to a newer version but I need to get Interface bonding active.

The OS is OpenSUSE 10.2 and added the following lines to /etc/modprobe.conf.local:

alias bond0 bonding
options bond0 miimon=100 mode=4 lacp_rate=1

and created a new file in /etc/sysconfig/network called ifcfg-bond0 with:

DEVICE=bond0
STARTMODE='onboot'
BONDING_MASTER='yes'
BONDING_SLAVE_1=eth0
BONDING_SLAVE_2=eth1
USERCONTROL='no'

IPADDR=172.23.4.137/23
NETWORK=172.23.4.0
BROADCAST=172.23.5.255
GATEWAY=172.23.4.254
DNS1=8.8.8.8
DNS2=8.8.4.4

On the ifcfg files of the physical interfaces:

DEVICE=eth0
STARTMODE=auto
BOOTPROTO=none
USERCONTROL=no
MASTER=bond0

for eth1 the same except the DEVICE name ofcourse.

The bond0 interface is brought up, but the HW address is 00:00:00:00:00:00 and the txqueuelen is also 0 No default gateway is set and when trying to do a ping or anything the error is: Network is unreachable

I tried several other options that work perfectly on CentOS or Ferdora (all newer OSes) but not on this old OpenSUSE 10.2 OS.

Anyone an idea?

  • I sort of got it working by typing the following command: "ifenslave bond0 eth0 eth1" on the command line. but after a reboot that is lost. I need to have it working automatically at boot. – SHLelieveld Jul 6 '16 at 9:32
1

Added the following line to the /etc/rc.d/rc3.d/S05network start script:

ifenslave bond0 eth0 eth1
sleep 2

and changed the following in the config files: /etc/sysconfig/network/ifcfg-bond0

DEVICE=bond0
STARTMODE=onboot
BOOTPROTO=none
NM_CONTROLLED=no
USERCONTROLLED=no
BONDMASTER=yes
IPADDR=172.23.4.237
NETMASK=255.255.254.0

/etc/sysconfig/network/ifcfg-eth0

DEVICE=eth0
STARTMODE=onboot
BOOTPROTO=none
USERCONTROL=no
MASTER=bond0
SLAVE=yes

/etc/sysconfig/network/ifcfg-eth1

DEVICE=eth1
STARTMODE=onboot
BOOTPROTO=none
USERCONTROL=no
MASTER=bond0
SLAVE=yes

/etc/sysconfig/network/routes

default 172.23.4.254 0.0.0.0 - 

/etc/resolv.conf

nameserver 172.23.5.254
nameserver 172.23.3.254
search nmc

And added the following lines to: /etc/modprobe.conf.local

alias bond0 bonding
options bond0 mode=4 miimon=100 lacp_rate=1

even after restart the interfaces are brought up fine and the cisco switch accepts this config (with config line: channel-group mode active)

Reminder this is on OpenSuse 10.2 that works for me. On CentOS 6.x and 7.x and Fedora 20+ it works a little different.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.