Their approach https://wiki.debian.org/InstallingDebianOn/Apple/MacBookAir/3-2 does not work(everything goes fine but usb does not become bootable). It also seems seems several years old and outdated. Other distos have large amouts of troubleshooting this issue, but not debian. Any advice how can I debug why my usb did not becamse Debian bootable after those procedures.

My steps were:

1)erase usb drive using disk utils and create FAT partition(i tried also exFAT and OSX Extended).

2) downloaded the iso and converted it to img:

hdiutil convert debian-8.4.0-i386-DVD-1.iso -format UDRW -o debian-8.4.0-i386-DVD-1.img

and renaming the result to remove the ".img" from name. I also tried to us UDTO instead of UDRW.

3) finding my usb location using diskutil list, it was /dev/disk2

4) unmounting the usb: diskutil unmountDisk /dev/disk2

5) dding the image: sudo dd if=debian-8.4.0-i386-DVD-1.img of=/dev/disk2 bs=1m

what took several hours. The result was the expected message that usb could not be read.

6) ejecting the usb with: diskutil eject /dev/disk2

The result was that the usb was not bootable - in the loading screen pressing alt button - the usb does not show.

3 Answers 3


I didn't convert the ISO to img, I just formatted a USB drive for FAT and used dd:

sudo diskutil unmountdisk /dev/disk1
sudo dd if=./debian.iso of=/dev/disk1 bs=1m

I tested this with Debian 9.

It's important to note that the appropriate /dev/disk# should be determined by using the following command on the macOS command line:

diskutil list

In the question above, the USB device mapped to /dev/disk2 whereas the example above uses /dev/disk1. But the number could be 3 or 4 or some other number. Ensure the number correlates with the memory stick you use; you risk losing data if you get it wrong.


Use unetbootin : https://unetbootin.github.io/. Here is a tutorial for ubuntu but you can also use it for debian just change the image :http://www.ubuntu.com/download/desktop/create-a-usb-stick-on-mac-osx

  • I tried, but it does not work. The usb becomes bootable, but if I try to load from it - grub brings the error message that it cannot find the kernel - "vmlinuz not found". Jul 5, 2016 at 9:23
  • Do you use uefi bios? Do you want to use the usb drive on the mac?
    – LXGA
    Jul 5, 2016 at 9:26
  • I think it is efi machine. I just need to create bootable linux usb so I can install it on mac machine. Jul 5, 2016 at 9:34
  • 1
    You downloaded only a part of debian!!!!! You selected DVD-1!!! Debian is big so if you dont use dvd download netinstall(it will boot from usb and download packages from online) : debian.org/distrib/netinst
    – LXGA
    Jul 5, 2016 at 9:39
  • 2
    The debian installer now warns against using unetbootin, i suggest that you UNaccept this answer and choose one of the others below: debian.org/releases/jessie/amd64/ch04s03.html.en
    – gotjosh
    May 30, 2019 at 7:59

I've used unetbootin in the past just fine however recently I was trying to install on a really old PC for use as a server and it would hang at the USB boot menu when I tried to boot over USB.

I managed to install Debian successfully using this guide which I've duplicated in my answer

The idea is the following:

  1. Download the boot.img.gz for the relevant version of Debian from here. You will need to change the version to make it match the ISO that you have. http://ftp.debian.org/debian/dists/stable/main/installer-amd64/current/images/hd-media/

  2. Unmount the target USB disk

  3. run gzip -dc boot.img.gz > /dev/disk# to your respective usb

  4. After it finishes (it took an oddly long time for a 50MB image, compression I guess), disconnect and reconnect the drive. Simply drag and drop the ISO into the root of the newly created partition.

Try and install! Worked for my Dell Optiplex 380


You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .