2

When I ssh from GNOME Terminal (tried different 14.04/16.04 distros, currently on Mint 18) to OS X, I have a unicode issue, e.g. the prompt is not properly displayed.

enter image description here

On OS X, I have bash 4.x as a default shell, installed via macports (and it's working fine when used from OS X Terminal).

By accident, I found out that if I run bash once I have ssh'ed in, the new shell don't have the unicode issue (until I exit to the previous shell).

Any ideas ?

(BTW, my locales variables are all set to en_US.UTF-8).

migrated from askubuntu.com Jul 3 '16 at 17:15

This question came from our site for Ubuntu users and developers.

  • The nature of the problem isn't clear from the description. – Thomas Dickey Jul 3 '16 at 17:22
  • I tried to copy/paste the mangled prompt, but the displayed characters are not properly copied/pasted. – Rhangaun Jul 3 '16 at 17:33
  • A screenshot helps. More complicated, you could capture the characters using script and paste the cat -v typescript as more-or-less readable text. – Thomas Dickey Jul 3 '16 at 17:35
  • 1
    This is not a Unicode issue at all. OSC 1337 are custom to iTerm2's shell integration and are not supported by gnome-terminal. – egmont Jul 3 '16 at 18:06
  • 1
    Then it's a bug in gnome-terminal (if it doesn't recognize a validly-formatted OSC, then it should echo nothing). A good answer would point out when it was fixed. – Thomas Dickey Jul 3 '16 at 18:13
1

I could reproduce the problem between Debian 8.9 with Bash 4.3.30 and Gnome Terminal 3.14.3.

The comment from rhangaun gave the answer: The problem is the .iterm2_shell_integration.bash integration. For iterm2 on mac it was initialized in my .profile file on the server.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.