1

I know this has been asked a lot before, but after 2 days of reading I still have not found a fix. I have a new Dell XPS 15 which does not have physical buttons on the touchpad. The problem is that if I rest my finger on the button area in order to be ready to click, the synaptics driver detects it(while it should not) and does not allow me to operate with another finger on the touchpad. Other functions such as drag and drop do not work as well.

So far I have tried fixes such as adjusting AreaBottomEdge option in synaptics but that merely removes the functionality to register movements below the specified edge - i.e. finger movements are not detected but finger touching the pad is detected.

Another fix I tried is

sudo modprobe -r psmouse
sudo modprobe psmouse proto=imps

This made the driver stop detecting any finger in the bottom area but removed all scrolling functionality. On a separate note - I would really appreciate if somebody explains what proto=imps does and if there is any way I can bring back the scrolling functionality. Also tried proto=bare but result was the same.

Also read through this bug report https://bugs.launchpad.net/ubuntu/+source/xserver-xorg-input-synaptics/+bug/1026046 (note I am using SlackWare, not Ubuntu or Debian) but all the suggested fixes seem really messy(removing other functionalities) and os-version specific.

It has been almost 5 years since this problem started. Has anyone found a stable fix?

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.