3

I ran

sudo apt-get update && sudo apt-get dist upgrade

and it basically removed my LibreOffice installation. Now when I try to install it again using

sudo apt-get install libreoffice

it gave me dependency problems. So I executed

sudo apt-get purge libreoffice*

then I tried to install but same problem. I am getting this error

gameranand@serenity ~ $ sudo apt-get -f install libreoffice
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 libreoffice : Depends: libreoffice-base but it is not going to be installed
               Depends: libreoffice-calc but it is not going to be installed
               Depends: libreoffice-core (= 1:5.2.0~rc1-0ubuntu1~xenial1) but it is not going to be installed
               Depends: libreoffice-draw but it is not going to be installed
               Depends: libreoffice-impress but it is not going to be installed
               Depends: libreoffice-math but it is not going to be installed
               Depends: libreoffice-report-builder-bin but it is not going to be installed
               Depends: libreoffice-writer but it is not going to be installed
               Depends: libreoffice-avmedia-backend-gstreamer but it is not going to be installed
               Depends: python3-uno (>= 4.4.0~beta2) but it is not going to be installed
E: Unable to correct problems, you have held broken packages.

How do I fix this. I really need the solution because I use Libreoffice on daily basis.

  • Perhaps try installing with aptitude instead of apt-get? – clk Jul 2 '16 at 19:15
  • Tried that too...No avail. – Gameranand Jul 2 '16 at 19:16
  • Try to install each of the packages on that list starting with apt-get install libreoffice-base. The libreoffice package is just a bundle of packages, if the bundle is screwed (it might be) you can still e possible to install the packages one by one. – grochmal Jul 2 '16 at 19:23
  • 2
    dist upgrade is dangerous in mint, since it uses ubuntu repos but not all of them and it does not have all the ubuntu extras either. – grochmal Jul 2 '16 at 19:24
  • Tried installing packages one by one. Same problem. Yeah Now I know dist-upgrade is dangerous. Won't run it again if it tries to screw up my installations. But in the meantime please give me the solution for this problem. – Gameranand Jul 2 '16 at 19:32
1

Both Ubuntu (Trusty > Xenial) and Linux Mint (Rosa > Sarah) have just had a distribution update, this might have caused the dependence problems. For me, on Mint Rosa 17.3, Libreoffice works fine and doesn't show an available update (installed version 1:5.0.3~rc2-0ubuntu1~trusty2). If you have very recently updated to Mint 18 I suggest posting this issue on the Linux Mint forums.

Otherwise try installing an older version of Libreoffice (not based on Ubuntu xenial, but Ubuntu trusty). See: https://askubuntu.com/questions/138284/how-to-downgrade-a-package-via-apt-get

Or, if you're feeling lucky, a complete rollback from the dist upgrade: http://crunchbang.org/forums/viewtopic.php?id=15750. I have never tried this myself, so I don't know how well that will work.

Remember to always use apt-get upgrade in the future :).

  • Thanks. I knew something was the problem, I just didn't know what. I just uninstalled the Libre and reinstalled from the site. I needed the features of Libre 5. – Gameranand Jul 17 '16 at 14:10

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.