I'm trying to open ports on my fedora OS.

In the past, this was as easy as adding an rule like

-A INPUT -m state --state NEW -m tcp -p tcp --dport 80 -j ACCEPT

I went to restart my iptables service and there is none. I went to install iptables and yum says it's installed and up to date (version 1.4.x)

How do I get the service?

EDIT: The answer is below, but I also wanted to let people know, if you're having trouble adding the rule to the /etc/sysconfig/iptables config... I would recommend using the $> system-config-firewall command to bring up a gui port editor that appears to work with the command below to restart the ipstables service via systemctl

  • iptables is not a system service. It is a frontend to the netfilter packet filter inside the kernel. You shouldn't need to start it. – jw013 Jan 18 '12 at 0:42
  • All the tutorials show me editing the /etc/sysconfig/iptables to add 80 accept as a rule..and then to restart that service-- How would I go about opening port 80? – OnResolve Jan 18 '12 at 1:32
up vote 3 down vote accepted

In Fedora 16, the approach to restart service has taken a giant (flighted) leap from SysV init script style to systemd approach.

To stop, disable, enable, start iptables service via systemctl command.

[root@fedora ~]# systemctl stop iptables.service 
[root@fedora ~]# systemctl stop ip6tables.service 
[root@fedora ~]# systemctl disable iptables.service 
rm '/etc/systemd/system/basic.target.wants/iptables.service'
[root@fedora ~]# systemctl disable ip6tables.service 
rm '/etc/systemd/system/basic.target.wants/ip6tables.service'

After configuring iptables rules, save them to some file like:

[root@fedora ~]# iptables-save > /etc/sysconfig/iptables
  • also check out "systemctl list-units" for a list of all the things systemctl knows about. – Sirex Jan 18 '12 at 7:48

Your Answer

 

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.