0

I bought a 3.0 USB especially for the job but I'm about to give up for the day. I wanted to try basic Arch, then I tried makeiso, then antergos. I have 3 iso images all behaving the same way. Like this:

I use Rufus to make the iso image. It completes successfully ( I can see the files + autorun etc..). I then go to Window's Advanced Startup Options/Recovery and 'Restart'. When I get the option, I choose 'Boot from Other Device, USB etc..') Then on the next screen I pick my new sandisk stick.

Then it just starts as normal. I have tried loads of different ISOs and tried different permutations of options on Rufus. What should I check next?

  • 1
    iso images are for CDs, not USBs. You could try the Debian live ISO, it is a hybrid ISO/Usb image (so will work with both). – ctrl-alt-delor Jun 30 '16 at 20:51
  • Rufus tells me to choose an iso image. Are you sure about this? I thought the whole idea is that it behaves like a disk? #moreConfusedNow :) – HellishHeat Jun 30 '16 at 20:52
  • 1
    It does but CD disks are different, they use ISO9660 file-system with El Torito boot loader extension, and juliet & rockridge extensions for long file-names and file attributes. This file-system came about because existing file-systems, for Microsoft OSs sucked, and it was infeasible to get Microsoft OSs to read Unix file-systems, as these had more that 11 character file-names. And so a new file-system was born, but only for CDs. Latter there was UDF (ISO/IEC 13346) for DVDs and blue-ray. But the short answer is that many computers can only boot ISO9660 from CD, and USBs as if a hard-disk. – ctrl-alt-delor Jun 30 '16 at 21:08
  • 1
    From the text on the arch website that you link to, it seems as though their image is a hybrid as well. As they say it works on USB. If so then you need to look at your firmware-bootloader settings (often incorrectly called bios). see also unix.stackexchange.com/questions/115792/… – ctrl-alt-delor Jun 30 '16 at 21:12
0

I found the answer in the link kindly supplied by richard above in the comments.

unix.stackexchange.com/questions/115792/

Basically I had to do go into BIOS and disable 'Secure Boot', then enable 'Legacy Boot'. After this, the steps outlined in my question worked.

Thanks.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.