1

I have recently installed Ubuntu 14.0.1 version on my machine. I use a proxy server to access internet and for this I have to provide the necessary IP address of the proxy server, port number and my authentication credentials. Here is how my /etc/apt/apt.conf looks like

Acquire::http::proxy "http://username:password@192.168.1.107:3128/";
Acquire::https::proxy "https://username:password@192.168.1.107:3128/";
Acquire::ftp::proxy "ftp://username:password@192.168.1.107:3128/";
Acquire::socks::proxy "socks://username:password@192.168.1.107:3128/"

Here mtan_201412 is username and zq8ap612g5 is the password.

After installing the Ubuntu OS, I made the above apt.conf file and then ran the command

sudo apt-get update

I got a similar output as

enter code here
Ign http://archive.ubuntu.com trusty-backports/multiverse Translation-en_IN
Ign http://archive.ubuntu.com trusty-backports/multiverse Translation-en
Ign http://archive.ubuntu.com trusty-backports/restricted Translation-en_IN
Ign http://archive.ubuntu.com trusty-backports/restricted Translation-en
Ign http://archive.ubuntu.com trusty-backports/universe Translation-en_IN
Ign http://archive.ubuntu.com trusty-backports/universe Translation-en
Err http://archive.ubuntu.com trusty/universe 
Sources  407  Proxy Authentication Required
Err http://archive.ubuntu.com trusty/main
Sources 407  Proxy Authentication Required
Err http://archive.ubuntu.com trusty/restricted 
Sources 407  Proxy Authentication Required
Err http://archive.ubuntu.com trusty/multiverse 
Sources 407  Proxy Authentication Required
Err http://archive.ubuntu.com trusty/main i386 
Packages 407  Proxy Authentication Required
Err http://archive.ubuntu.com trusty/restricted i386
Packages 407  Proxy Authentication Required
Err http://archive.ubuntu.com trusty/universe i386 
Packages 407  Proxy Authentication Required
Err http://archive.ubuntu.com trusty/multiverse i386 
Packages 407  Proxy Authentication Required
Err http://archive.ubuntu.com trusty-security/universe 
Sources 407  Proxy Authentication Required
Err http://archive.ubuntu.com trusty-security/main 
Sources 407  Proxy Authentication Required
Err http://archive.ubuntu.com trusty-security/restricted 
Sources 407  Proxy Authentication Required
Err http://archive.ubuntu.com trusty-security/multiverse Sources

As is evident, there are some targets that get a hit while for others, The proxy authentication failed message is displayed. Then the above apt.conf file automatically gets changed to

Acquire::http::proxy "http://192.168.1.107:3128/";
Acquire::https::proxy "https://192.168.1.107:3128/";
Acquire::ftp::proxy "ftp://192.168.1.107:3128/";
Acquire::socks::proxy "socks://192.168.1.107:3128/";

This thing happens repeatedly. Its really frustrating to keep on editing the the apt.conf file to include credentials. Why is it happening?

Prior to this, I was using the same OS. I used to enter network proxy settings in the System Settings->Network->Network Proxy tab and put the credentials in the apt.conf file and everything (update, upgrade and software install through software-center) used to take place without any problem. Now I am able to upgrade the system using

sudo apt-get upgrade

But I am not able to use Software Updater GUI edition and software center to install any software.

Why am I facing this problem now?

I am also including the software settings enter image description here enter image description here enter image description here

  • Where do you see that some accesses worked? I only see Ign (not downloaded but translations are optional so the failure was ignored) and Err (error, the next line explains why). – Gilles Jun 30 '16 at 22:21

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.