1

I'm trying to use remote desktop on my LAN to access a machine's gui from another computer. The machine I am working on is Ubuntu14.04LTS using KDE desktop. The target machine is CENTOS7 with MATE desktop.

When i try to remote desktop from my Ubuntu machine using KRDC (for KDE desktop) or Vinagre using the vnc protocol, I get the following desktop:

enter image description here

Here is a screenshot of my settings when using Vinagre. I have the same problem when I used KRDC:

enter image description here

That desktop doesn't even look like the default desktop of my user (only one user on the target system). And it looks like a browser with the menu hidden. I don't know what that's about. I'm not sure what to do next for troubleshooting.

The remote machine was started as a minimum install of CENTOS7 and then the mate desktop was installed. The system currently boots fine and defaults to the mate desktop when I am in front of the machine.

The target machine has tigervnc-server installed and I'm not trying to do a desktop share. I'm trying to use the target machines GUI rather than doing everything via terminal. So what I was expecting to see was the default desktop for my user...but i got something completely different.

Can anybody provide any direction here?

If the issue is related to this, can someone clarify what I need to change in CENTOS7?

1

I found a solution for the MATE desktop on a CENTOS7 system. For the user account on the target system, replace the following in ~/.vnc/xstartup

#!/bin/sh

unset SESSION_MANAGER
unset DBUS_SESSION_BUS_ADDRESS
exec /etc/X11/xinit/xinitrc

with:

#!/bin/sh

unset SESSION_MANAGER
unset DBUS_SESSION_BUS_ADDRESS
#exec /etc/X11/xinit/xinitrc
/usr/bin/mate-session

[ -x /etc/vnc/xstartup ] && exec /etc/vnc/xstartup
[ -r $HOME/.Xresources ] && xrdb $HOME/.Xresources
xsetroot -solid grey
vncconfig -iconic &
x-terminal-emulator -geometry 80x24+10+10 -ls -title "$VNCDESKTOP Desktop" &
x-window-manager &

Rebooted the target machine, and everything is working as expected.

Source

This is just a solution to get it working. I still would like to find out exactly which lines above (if not all) are absolutely necessary for the desired results.

0

You have to change setting in .vnc/xstartup file with

#!/bin/sh
unset DBUS_SESSION_BUS_ADDRESS
[ -x /etc/vnc/xstartup ] && exec /etc/vnc/xstartup

[ -r $HOME/.Xresources ] && xrdb $HOME/.Xresources

xsetroot -solid grey

vncconfig -iconic &

x-terminal-emulator -geometry 80x24+10+10 -ls -title 
"$VNCDESKTOP Desktop"&

mate-session &

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.