2

I just installed Debian 8.5 CD install on my Toshiba Satellite machine, not in a VM. As it was setting up it told me that some iwlwifi and rtl files were missing, but it didn't really matter as I thought I could add them later.

Using a usb stick, I downloaded firmware-iwlwifi and firmware-realtek, used dpkg -i on both and my previously empty /lib/firmware is now populated with a lot of iwlwifi files and a directory /lib/firmware/rltwifi with quite a bit of rlt files. After reboot, ifconfig still only listed lo. Downloaded and installed iwconfig to see if I can wake up wlan0 manually, but it still didn't work.

In the Ask Ubuntu General Room they asked me the output of lsmod | grep iwlwifi, which showed that indeed I have the driver installed

rfkill wasn't installed, and after installation via USB no connection was blocked, but it had found an hci0 and phy0

dmesg | grep wifi outputs (all under [ some numbers] iwlwifi 0000:07:00.0:):

irq 66 for MSI/MSI-X
Unsupported splx structure
firmware: direct-loading firmware iwlwifi-3160-9.ucode
loaded firmware version 23.215.9.0 op_mode iwlmvm
Detected Intel(R) Dual Band Wireless AC 3160, REV=0x164
L1 Disabled - LTR Enabled
L1 Disabled - LTR Enabled

output of lspci -nn | grep 0280: 07:00.0 Network Controller [0280]: Intel Corporation Wireless 3160 [8086:08b3] (rev cb)

I don't have a desktop environment yet, so only terminal answers please, althought it is possible to set up MATE or GNOME via USB

Is there anything I'm missing? Currently browsing from an old windows machine

  • 1
    Please edit your question and add the output of lspci -nn | grep 0280. Are you sure your card needs the iwlwifi driver? – terdon Jun 29 '16 at 9:26
  • @terdon done. Pretty sure, as it asked for those files on boot – towc Jun 29 '16 at 9:49
0

Install network-manager , some dependencies need to be installed to get wifi working:

aptitude install network-manager

install the wireless-tools:

aptitude install wireless-tools

The right driver is installed according to your question.

additional info : iwlwifi is a non-free firmware , it can be installed by adding a non-free to your /etc/apt/sources.list then run:

aptitude install firmware-iwlwifi

Load the iwlwifi driver

modprobe -r iwlwifi ; modprobe iwlwifi

Add the following line to /etc/modprobe.d/iwlwifi.conf and reboot:

options iwlwifi bt_coex_active=0 swcrypto=1 11n_disable=8

bring up your wifi interface:

ip link set wlan0 up

Then run the following commands:

cp /usr/share/doc/wpasupplicant/examples/wpa-roam.conf /etc/wpa_supplicant/wpa_supplicant.conf

chmod 0600 /etc/wpa_supplicant/wpa_supplicant.conf

Create wpa_supplicant.conf:

wpa_passphrase your-ssid-here your-passwd-here >> /etc/wpa_supplicant/wpa_supplicant.conf

To scan use:iwlist wlan0 scan or iw wlan0 scan .

To connect run the following command:

wpa_supplicant -B -D wext -i wlan0 -c /etc/wpa_supplicant/wpa_supplicant.conf
dhclient wlan0
| improve this answer | |
  • aptitude doesn't seem to be a command. And assume I don't even have an ethernet connection – towc Jun 29 '16 at 14:00
  • Edit , and add the output of lspci | egrep -i 'network|ethernet' – GAD3R Jun 29 '16 at 15:17
  • I ge both a network and an ethernet controller with no errors – towc Jun 29 '16 at 16:33
  • The output will give the information about the needed driver to be installed to get the internet working. – GAD3R Jun 29 '16 at 17:05

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.