1

I am on Linux Mint 17.3 Cinnamon.

I am trying to boost my Wi-Fi signal well under our country specification.

Suppose my maximum TX power allowed by our law is 20.

Ok, now my integrated laptop card is running at 15.

iwconfig wlan0

shows this

wlan0     IEEE 802.11bgn  ESSID:"mySSID"  
          Mode:Managed  Frequency:2.472 GHz  Access Point: myMAC   
          Bit Rate=1 Mb/s   Tx-Power=15 dBm   
          Retry short limit:7   RTS thr:off   Fragment thr:off
          Encryption key:off
          Power Management:off
          Link Quality=70/70  Signal level=-40 dBm  
          Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
          Tx excessive retries:0  Invalid misc:106   Missed beacon:0

Problem is the connection drops if I go to the next room, where the signal quality drops rapidly.

What I've tried:

Turning off Wi-Fi:

ifconfig wlan0 down

All over the internet I read about changing to region to less restricted country, so I say Why not?:

iw reg BO

I even switched my router to Bolivia and changed to channel 13.

Then trying to boost the txpower:

iwconfig wlan0 txpower 20

And bringing the Wi-Fi back on:

ifconfig wlan0 up

Then, I verified if it is running on Bolivia regulatory restrictions:

iw reg get

And it does:

country BO:
    (2402 - 2482 @ 40), (N/A, 30)
    (5735 - 5835 @ 40), (N/A, 30)

I know the step of switching to BO country was unnecessary, still I had to try it.

The following command simply does not do as I say, verified by iwconfig wlan0:

iwconfig wlan0 txpower 20

I tried txpower 16, which is only 1 up with no success.

I have identified the Wi-Fi card by:

lspci | grep -i wireless

as:

03:00.0 Network controller: Qualcomm Atheros AR9485 Wireless Network Adapter (rev 01)

Can someone help me boost it even slightly? Thank you.

1

You will likely fail using an Atheros wifi card as they have a code written to EEPROM and that is how they decide what channels are used and TX power limits are enforced. You can see for yourself using dmesg | grep ath and you will see a line like ath: EEPROM regdomain: 0x60 this in many cases overrides any CRDA or regdomain setting

I am not sure boosting the TX Power is going to help if the signal strength from the router drops significantly in the next room as you would also need to boost the router's TX power

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.