12

I just followed the answer in: How to install Octave without GUI in Ubuntu 16.04? to install octave in ubuntu 16.04 and apparently it worked fine.

Running octave-cli in terminal apparently works

But when I went to run octave clicking on its icon I got the following error:

The settings file /home/user/.config/octave/qt-settings does not exist and can not be created.

Make sure you have read and write permissions to /home/user/.config/octave

Octave GUI must be closed now.

Can anyone please help me fix this, so I can run octave?

  • 2
    There are 2 answers in the question you linked, and note that the answer with more upvotes offers 2 methods. Which answer and method did you actually follow? – edwinksl Jun 28 '16 at 23:42
  • Which ever you think is the best one. I'd probably go for the one with more upvotes, because if one of the methods doesn't work I can always try the other one. – Joao Jun 29 '16 at 23:10
31
cd .config/octave

sudo chown $USER qt-settings
  • This solved my problem on Ubuntu 16.04. Thank you! – Andrea Nov 4 '16 at 9:25
  • This works also for Ubuntu 16.10. Thanks! – David Georg Reichelt Jan 20 '17 at 20:56
3

You can use "sudo octave" from the terminal in order to give access to octave. The con is that you have to open octave every time by this way.

1

What helped me on ubuntu 14.04 is the following

cd .config/octave/

sudo chmod u+w qt-settings
  • I followed your suggestion, but nothing happens after that. – Joao Jun 30 '16 at 0:38
0

I had the same problem. This worked for me:

cd ~/.config/octave 
sudo chown user:user qt-settings
sudo chmod u+w qt-settings

In place of the word "user" you must place your username.

0

Got this problem on 17.04. The problem is the permissions of the folder, not the file.

I did this:

sudo chown user .config/octave
sudo chown user .config/octave/qt-settings

and then Octave opened OK.

0

The problem is, that somehow the program doesn't see that who is the owner of the program. For that you need to do the following (that was mentioned by everyone) :

cd .config/octave

sudo chmod qt.settings

After this, open terminal and type: Octave. The program will run

My system: ubuntu 17.04 upgraded to gnome3

-2
cd .config/octave/
sudo chmod u+w qt-settings

cd .config/octave
sudo chown user qt-settings

*works for me even 16.04

protected by Community Oct 10 '18 at 17:44

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.