2

I have a serial connection made with /dev/ttyUSB0 locally from my laptop to a cisco lab router and using minicom/putty/screen all work fine locally (hardware control: on, software control: off, 9600 8N1).

When I'm at work I SSH into my laptop at home, which works fine, but when I use minicom/screen to use the lab router I get garbage characters. I tried SSHing at home from another machine and it worked fine initially, but then later it started having garbage characters.

Since this is only happening over an SSH connection, what could be causing this? Any setting changes that could fix this?

5
  • Just guessing, the $TERM env. variable could play a role?
    – phk
    Jun 28 '16 at 17:59
  • 1
    Could you be more specific what you mean with "garbage characters"? Some garbage in the middle? Or total garbage at some point with no end?
    – phk
    Jun 28 '16 at 18:00
  • some garbage, so rather than "Password:" it would instead show something like "rrj:" and rather than the banner message of "this is the banner message" it would come up "akjkj dd i" I'm thinking it may have something to do with the roll over cable or the serial to usb cable though as I put the cisco router on my network and I've been able to ssh into it all day just fine, no garbage at all.
    – Nate
    Jun 29 '16 at 17:32
  • Very strange. For my serial devices I normally only see single characters I haven't added after some time but output is largely OK. I did see problems you describe when I tried to connect to a serial port several times but then the garbage would basically be everywhere. Same goes for wrong settings.
    – phk
    Jun 29 '16 at 22:21
  • Since it is only happening in SSH mode, it's likely that there is some problem with the quality of transmission (flow control), since SSH, being encrypted, is more sensitive to disturbance than plain text. Sep 7 '16 at 1:26
0

For me, the issue got resolved by setting a "character tx delay" of 1 ms in minicom:

CTRLA, Z, T, F, 1, ,

minicom screenshot

There doesn't seem to be such a setting in screen. However, see How to set "character tx delay" in GNU screen? (Like in minicom) for something similar.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.