0

I installed veil-evasion recently and after I reboot kali, it stuck at log-in screen. I'm entering my credentials but after that a black screen appears for a short time and it takes me back to the log-in screen. I re-installed kali for several times. but whenever i install veil, rigth after this problem occured. Here's what i tried to solve this:

With pressing Ctrl+Alt+F3 I log into the shell. And then:

  1. I reinstalled and configured gdm3

  2. I installed and configured lightdm instead of gdm3

  3. I installed xorg, type startx and then reboot it.

  4. I couldn't look xsessions-errors cause it doesn't exist in my system. Instead of that, I did this:

cd /usr/share/xsessions and here's what ı've got:

gnome-classic.desktop gnome.desktop (but i have no permission to access them)

  1. I typed "chown username:username .Xauthority" but it there was no response

  2. One of the suggestions was typing them:

    sudo mv ~/.Xauthority ~/.Xauthority.backup
    

sudo service lightdm restart But "Xauthority" wasn't a file or directory

  1. I typed apt-get install x-window-system and after that startx

They were solutions that i find in several forums so I just did what they wrote. None of them worked obviously. Any ideas?

-1

The following worked for me.

  1. Ctrl+Alt+F3
  2. apt-get update
  3. apt-get upgrade

protected by Community Jan 18 '17 at 8:38

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.