NTFS: Input/output error

I was experimenting with HDF5 installation from a permanently mounted NTFS data partition so lots of deletion etc. Now part of the folder (containing some codes etc.) is not deleting and showing the above error. I have already NTFS-3g etc. but only have windows on virtualbox (from which also can not delete). Thanks for all the help!

I am on CentOS 7.

  • How is that NTFS partition mounted on your Windows VM? Jun 28, 2016 at 4:38
  • @Julie: The OP has tages nrfs-3g that means he has used it ntfs-3g for mounting the filesystem. hope he reply to confirm
    – AReddy
    Jun 28, 2016 at 5:44
  • I used centos 7 fstab entry 'UUID=4A6C45276C450F5F /mnt/Various ntfs defaults 0 0' to mount. In VM win 7 it is mounted as shared folder
    – ankhi
    Jun 28, 2016 at 9:24
  • Sometimes, you can fix NTFS partitions easily using Window 10. Mar 1, 2020 at 23:38

3 Answers 3


This means your filesystem is damaged, Input/Output errors during filesystem access attempts generally mean hardware issues.

Type dmesg and check for log. it might be because of connection to it is failing, it'll be noted there.

is it mounting it via ntfs or ntfs-3g ? As I recall, the legacy ntfs driver had no stable write support and was largely abandoned when it turned out ntfs-3g was significantly more stable and secure.

  • it is mounted as 'UUID=4A6C45276C450F5F /mnt/Various ntfs defaults 0 0' . should I make it ntfs-3g?
    – ankhi
    Jun 28, 2016 at 9:27
  • @ankhi first of all you should fix it (with chkdsk in Windows). Jun 28, 2016 at 12:48
  • I have only virtualbox windows hence I cant use chkdsk
    – ankhi
    Jul 6, 2016 at 13:16

I meet the same problem,too.Some topics tell me that I should mount this disk on Win and rm it and clean the trash.I tried but failed.

But,I rm this files parent folder (on Linux rm -rf xxx ),and solved this problem.

U can try this way but remember to copy the import files or folders in parent folder.


Read about mount / umount (man pages)

In my case directory had be to unmount first, to be eligible to be deleted itself or its subdirectories/files

sudo umount -f /media/sami/OS\somewindows_folder

Then simply sudo rm -rf /media/sami/OS\somewindows_folder worked for me

  • This is absolutely not an issue of mounting. You're not deleting anything on the actual external drive since you've just unmounted your drive. You are simply running rm on an empty/nonexisting path (since nothing is mounted at /media/sami/OS anymore) but it fails silently since you're using the -f switch. This consequently accomplishes absolutely nothing. You definitely should read about what mounting is.
    – adamency
    Aug 8 at 17:41

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .