2

I'm using ASUS Chromebook Flip with Google Chrome OS 53.0.2773.3.dev:

chronos@localhost / $ cat /etc/os-release
NAME=Chrome OS
ID_LIKE=chromiumos
GOOGLE_CRASH_ID=ChromeOS
BUG_REPORT_URL=https://crbug.com/new
HOME_URL=https://www.chromium.org/chromium-os
ID=chromeos
chronos@localhost / $ cat /etc/lsb-release 
CHROMEOS_ARC_VERSION=2992394
CHROMEOS_AUSERVER=https://tools.google.com/service/update2
CHROMEOS_BOARD_APPID={432FF9F1-4D2E-7E74-6F98-32E56E904BFB}
CHROMEOS_CANARY_APPID={90F229CE-83E2-4FAF-8479-E368A34938B1}
CHROMEOS_DEVSERVER=
CHROMEOS_RELEASE_APPID={432FF9F1-4D2E-7E74-6F98-32E56E904BFB}
CHROMEOS_RELEASE_BOARD=veyron_minnie-signed-mp-v3keys
CHROMEOS_RELEASE_BRANCH_NUMBER=2
CHROMEOS_RELEASE_BUILD_NUMBER=8481
CHROMEOS_RELEASE_BUILD_TYPE=Official Build
CHROMEOS_RELEASE_CHROME_MILESTONE=53
CHROMEOS_RELEASE_DESCRIPTION=8481.2.0 (Official Build) dev-channel veyron_minnie 
CHROMEOS_RELEASE_NAME=Chrome OS
CHROMEOS_RELEASE_PATCH_NUMBER=0
CHROMEOS_RELEASE_TRACK=dev-channel
CHROMEOS_RELEASE_VERSION=8481.2.0
DEVICETYPE=CHROMEBOOK
GOOGLE_RELEASE=8481.2.0
chronos@localhost / $ uname -a
Linux localhost 3.14.0 #1 SMP PREEMPT Fri Jun 24 00:01:48 PDT 2016 armv7l ARMv7 Processor rev 1 (v7l) Rockchip (Device Tree) GNU/Linux
chronos@localhost / $ 

I'm trying to change root password and I'm getting following:

chronos@localhost / $ sudo passwd root
Enter new UNIX password: 
Retype new UNIX password: 
passwd: Authentication token lock busy
passwd: password unchanged
chronos@localhost / $ 

Any ideas why? and/or how to deal with it?

1

According to this link, you need to use sudo chromeos-setdevpasswd.

2
  • 2
    As I understand it, the command sudo chromeos-setdevpasswd allows you to change the password for the chronos user account, not for root. That may be the answer to the OP, but in my case, I really want to set the password for root, not for chronos, and I get the error described above.
    – fulv
    Sep 23 '16 at 0:12
  • @fulv When you power wash to developer mode, there is an option at the bottom of the screen that mentions "write access" (warning: when you set write access, I believe it powerwashes). Click this and you will be prompted to set a password. Then, after you login, press CTRL+ALT+F2 and login as root and use the password you set. After logging in as root, run the set password command as described in this answer. Then, press CTRL+ALT+F1 to get back to a regular screen.
    – mchid
    Dec 20 '19 at 6:48
0

Check that the root filesystem is mounted in read-write mode; if not, run mount -o remount,rw and then retry.

For example, I got this error while resetting the root password from recovery mode init=/bin/bash which already proved viable. After some forum research, it turned out that I just forgot the first step required to store the new password and proceed regular bootup with exec /sbin/init.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.