11

I recently did a clean install of Debian GNOME and updated from stable to testing. Before updating to testing, I had several GUI settings for my touchpad. After updating, they are gone as shown in the screenshot: Screenshot showing that options are missing

For example, I would expect to find the setting for natural scrolling on this settings page.

Opening this page from the terminal yields the following error message

$ gnome-control-center mouse

(gnome-control-center:15084): mouse-cc-panel-WARNING **: Detected synaptics X driver, please migrate to libinput

which indicates that the problem is related to libinput not being installed.

Running $ dpkg-query -l '*libinput*' in the terminal shows that libinput-bin, libinput10:amd64, libinput5:amd64 and xserver-xorg-input-libinput are installed.

Arch Wiki - Touchpad Synaptics says

Please note that if you want desktop integration (i.e. ability to configure touchpad via GNOME control center or KDE settings), you need xf86-input-libinput.

The xserver-xorg-input-libinput package, which is installed, is built from xf86-input-libinput referred to by Arch Wiki.

How can I solve my problem so that I get the missing settings back?

14

Having had the same issue, I fixed it following this procedure:

  • Install all libinput packages (libinput5, libinput10, xserver-xorg-input- libinput
  • Remove the synaptics driver → xserver-xorg-input-synpatics
  • Remove all synaptics related files in /etc/X11/xorg.conf.d/ (Like 50-synaptics.conf)
  • Reboot

And the touchpad is back in gcontrol-center.

Cause of the problem:

GNOME and most other desktop environments depended on the old "synaptic" drivers for touchpads. However, in GNOME 3.20, they have switched to libinput. The problem was because "xserver-xorg-input-synaptics" is a dependency of "xserver-xorg-input-all".

Source : https://lists.debian.org/debian-devel/2016/07/msg00266.html

  • 2
    Since I already had the libinput-bin, libinput10:amd64, libinput5:amd64 and xserver-xorg-input-libinput packages installed, I just needed to remove synaptics and the configuration files so I just ran sudo apt-get purge xserver-xorg-input-synaptics. Now it works! – lklun Jun 30 '16 at 6:34
  • Hi, you have a typo in the first line it should be xserver-xorg-input-libinput, instead of ...-corg-... – Jorge E. Cardona Nov 19 '16 at 1:28
  • This answer is fine as far as it goes; however the Synaptics driver provided a great variety of options through the synclient command line tool, and while some settings are available through xinput, xinput --list-props / xinput --set-prop and xinput --get-button-map / xinput --set-button-map, with a "SynPS/2 Synaptics TouchPad" in particular, there is not an apparent way to enable two-finger tapping as was available through synclient. – rakslice Aug 23 '18 at 22:40
  • Is there a way to tell gnome or gdm to load libinput over synaptics, instead of me having to purge the synaptics driver from my system? I'd like to keep both installed but loaded under different sessions. – theferrit32 Nov 16 '18 at 2:33

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.