I'm running Win10 as the host system, & Ubuntu inside a VirtaulBox.

I'm trying to migrate my ~/.config folder from inside the VM, to sit on the host system (I mapped my Dropbox folder as a permanent shared folder). I copied the content of ~/.config to the host system, and then made it a symbolic link.

Trouble is permissions / ownership. After the settings are moved to the shared folder, they stop updating, e.g. when I edit the default terminal window size, the changes won't stick.

Running dconf-editor gives:

(dconf-editor:2515): IBUS-WARNING **: The owner of /home/ripper234/.config/ibus/bus is not ripper234!

And it seems I cannot change the ownership of shared folders.

Any advice on making this setup work?


I tried remounting the folder, I'm not getting any errors but I can't find any mounts either:

$ sudo mount -t vboxsf -o remount,gid=ripper234,uid=ripper234,rw dropbox /media/sf_dropbox
$ ls -da /media/sf_dropbox/
drwxrwx--- 1 root vboxsf 4096 יונ 27 09:08 /media/sf_dropbox/
$ ls -l /mnt/
total 0
$ ls -d /media/dropbox
ls: cannot access '/media/dropbox': No such file or directory
$ mount | grep dropbox
/media/sf_dropbox on /media/sf_dropbox type vboxsf (rw,nodev,relatime)
  • Does the accepted answer to the linked question work for you? You can mount the shared folder so that all the files and directories in it appear to be owned by one given user and group. – Mark Plotnick Jun 26 '16 at 19:44
  • @MarkPlotnick tried it now, updated my attempts in the question body. – ripper234 Jun 27 '16 at 15:28
  • It's possible that the remount option doesn't work on your system. Please try unmounting the filesystem and then mounting it again, with the uid= and gid= options. – Mark Plotnick Jun 27 '16 at 16:29

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.