1

I want to compile guile on shared hosting but when I run ./configure I've got error:

configure: error: GNU MP 4.1 or greater not found, see README

so I've downloaded GMP and tried to install it locally (found in answer to this question on Stack Overflow install library in home directory)

mkdir /home/jcubic/lib
./configure --prefix=/home/jcubic/
make
make install

it created this files in /home/jcubic/lib

libgmp.a
libgmp.la
libgmp.so
libgmp.so.10
libgmp.so.10.3.1

then I've run configure from guile directory (found the option by reading configure script):

./configure --with-libgmp-prefix=/home/jcubic

but the error remain, how can I use local GNU MP file while running guile ./configure and make?

  • Have you also tried to set the LD_LIBRARY_PATH like described in the Stack Overflow post? You also might have to set the CPATH variable to /home/<user>/include. – Thomas Jun 26 '16 at 12:42
  • I've called ` LD_LIBRARY_PATH="/home/jcubic/lib/" CPATH="/home/jcubic/include/" ./configure --with-libgmp-prefix=/home/jcubic/` but got the same error. – jcubic Jun 26 '16 at 13:20
  • Hm...not really sure, but you also might need LIBRARY_PATH=/home/jcubic/lib as well. If that does not work, try with the configure script environment variables CFLAGS and LDFLAGS. – Thomas Jun 26 '16 at 13:37
  • setting LIBRARY_PATH work now I have another library missing error, you can add this as an answer. – jcubic Jun 26 '16 at 13:46
1

As a sum up of the comments. One has to add the environment variables as follows.

LD_LIBRARY_PATH="/home/<user>/lib" LIBRARY_PATH="/home/<user>/lib" CPATH="/home/<user>/include"

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.