9

I am using Arch Linux with GNOME 3.20. I am trying to get a network manager applet (tray-icon) using which I could easily connect to WiFi networks.

I installed networkmanager and network-manager-applet but I am not getting any tray icon.

enter image description here


As I found that this is a commen problem and has less resources to look for a step-by-step solution, I thought it would be helpful for new users if I share how I solved this problem.

15

Initial Requirements

Hosts

Check the configuration of your /etc/hosts file, a valid configuration looks like this:

        #<ip-address>    <hostname.domain.org>    <hostname>
        127.0.0.1      localhost.localdomain    yourHostname
        ::1            localhost.localdomain    yourHostname

Devices

You can identify your networking-devices like this:

$ lspci | grep -i net

If your device is not listed, it is maybe an usb-device, so try this command:

$ lsusb 

With the following command you can check the current state of all your network-devices:

$ ip link

Installation of Required tools

Install the wpa_supplicant tools

$ sudo pacman -S wpa_supplicant

Install the wireless tools

$ sudo pacman -S wireless_tools

Install the networkmanager

$ sudo pacman -S networkmanager

Install the network-manager-applet aka nm-applet

$ sudo pacman -S network-manager-applet

Install gnome-keyring

$ sudo pacman -S gnome-keyring

Configuration

Make the networkmanager start on boot:

$ sudo systemctl enable NetworkManager.service

Disable dhcpcd

Since networkmanager wants to be the one who handles the dhcpcd related stuff, you have to disable and stop dhcpcd:

 $ sudo systemctl disable dhcpcd.service
 $ sudo systemctl disable dhcpcd@.service
 $ sudo systemctl stop dhcpcd.service
 $ sudo systemctl stop dhcpcd@.service

Enable wpa_supplicant, if you want to use your wireless connection:

 $ sudo systemctl enable wpa_supplicant.service

Add your user to the network group:

 $ gpasswd -a <USERNAME> network

Turn off network interface controllers:

Turn off your network interface controllers, in my case eth0 and wlan0:

 $ ip link set down eth0
 $ ip link set down wlan0

Now start wpa_supplicant:

 $ sudo systemctl start wpa_supplicant.service

Now Start the networkmanager:

 $ sudo systemctl start NetworkManager.service

Now you should See the tray-icon on the top bar

enter image description here

If you get an error about unreachable D-Bus, just ignore it. If the networkmanager is not running and network-manager-applet does not show up in your upper GNOME3 panel, try this:

$ sudo Networkmanager
$ nm-applet

  • FYI this also worked for getting plasma-nm to work with KDE. THANK YOU. – James Irwin Nov 21 '17 at 14:03
  • works for XFCE too!! – noone Jan 1 '18 at 18:00

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.