2

I have a freshly setup Raspberry Pi 3 with OSMC; I can't login via ssh. I can open a shell when using my wireless keyboard, sudo -s works, and AFAICS, WiFi connection is fully functional, including DNS (which I verified by installing and using nslookup). I can ssh to my RasPi 1B with OpenElec (other machine, other OS, but same WiFi setup, using the same Fritz!Box and DHCP).

When I try to connect via ssh (both tried with PuTTY, and with a Ubuntu 14.04 netbook), I'm prompted for the user name, then for the password. After giving a wrong password, I'm prompted again; after giving the correct one, nothing happens anymore. (PuTTY gives up after after 20 seconds: "Network error: Software caused connection abort").

This is a permanent problem; with this "machine" and this OS, it has never worked for me.

I enabled debugging mode in the sshd configuration, and I put some log excerpt to http://termbin.com/0y7u. journalctl -u sshd didn't work (the output was empty), so I took the complete output and preserved all sshd lines and a few more. (will be online roughly until July 21st, 2016)

I first gave a wrong password (20:41:45), then the correct one (20:41:48).

Could the problem hide in the following final lines?

Jun 21 20:41:48 osmc sshd[777]: Starting session: shell on pts/0 for osmc from 192.168.178.26 port 52907
Jun 21 20:41:48 osmc sshd[778]: debug1: Setting controlling tty using TIOCSCTTY.

I assume it's another problem than in this question because I don't have this Received disconnect line.

Any ideas? Thank you!

Update: ssh -v osmc@osmc gives me the following output:

...
debug1: Next authentication method: password
osmc@osmc's password:
debug1: debug1: Authentication succeeded (password).
debug1: Authenticated to osmc ([192.168.178.30]:22).
debug1: chennel 0: new [client-session]
debug1: Requesting [email protected]
debug1: Entering interactive session.
debug1: Sending environment.
debug1: Sending env LANG = de_DE.UTF-8

This didn't terminate, even after a few minutes of waiting; ps a in another terminal gave me:

 PID TTY   STAT  TIME  COMMAND
1324 tty1  Ss    0:00  /bin/login --
1508 tty1  S     0:00  -bash
1564 tty1  S+    0:00  ssh -v osmc@osmc

I couldn't terminate the ssh call by Ctrl+C; kill 1564 worked, of course, and gave me two more lines:

debug1: free: client-session, nchannels 1
debug1: Killed by signal 15.

Update 2: I meanwhile installed a fresh raspbian system on another chipcard which I put in the same machine. Interestingly, I have the same problem; but when logged in with the wireless keyboard attached, I can do ssh localhost which works like a charm.

Now the original OSMC system won't boot anymore; perhaps it will after some sleep. But now I suspect there might be a problem with the kernel changes for RasPi 3, since the Raspbian system didn't let me ssh in either.

10
  • What is the output with -v to your ssh command using the netbook? Jun 26, 2016 at 13:16
  • you could try creating a new user with useradd from your sudo and logging in as that.
    – meuh
    Jun 26, 2016 at 14:36
  • @RalphRönnquist: I updated my question with this information added.
    – Tobias
    Jun 26, 2016 at 14:48
  • @meuh: I created the new user, as suggested, and sadly this didn't help.
    – Tobias
    Jun 26, 2016 at 15:19
  • have you managed to do regular auto system updates, or on-demand in the osmc screen?
    – meuh
    Jun 26, 2016 at 15:24

0

You must log in to answer this question.

Browse other questions tagged .