1

Upon installing zsh, the shell has displayed my name like

[\u@\h \W]\$

I tried adding

PROMPT='%n>'

to my .zshrc, but it does not seem to have helped.

  • That's a bash setting. You have a bash setting somewhere it shouldn't be. – Gilles Jun 26 '16 at 12:24
2

Your .zshrc line should be

PS1='%n>'
  • hmm, this doesn't seem to help, even after rebooting. – LonelyPyxel Jun 26 '16 at 3:37
  • Nitpick: there is no need to export PS1. It is sufficient to just set it within the same shell context, which is the case when it is set in the configuration file (or sourced from another file with source FILE or . FILE). It also may lead to broken prompts when starting a different shell, as demonstrated in OP's question. – Adaephon Jun 27 '16 at 9:42
  • @Adaephon Good to know. Thank you for the information. I guess i have some reading to do on export. Updating my answer. – Zachary Brady Jun 27 '16 at 10:14
0

Installed oh-my-zsh and everything seems to be working fine. Problem solved.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.