1

I'm logging onto a computer cluster over ssh. The problem is I can't do much more than that. Whenever I run things, eg: vim, cd, ls the cursor just hangs there and nothing else happens.

  • I've heard it could be something to do with MPUs? Not an expert so I don't know.
  • I was using a VPN but now I'm connected directly to the network and the problem still happens.

Do you have any idea why this could be?

Edit: thank you commentors for your suggestions. My sysadmin solved the problem for me, so your suggestions will have to remain suggestions as I can't verify them. However, please answer the question for any straggler who finds themselves with this obscure issue in the future.

  • Please update the original post of yours with the output from these commands: alias , echo ${PATH}, provided you can get a shell prompt. Sometimes, an erroneous escape sequence on your shell prompt, may turn it into a nothing, so even if you see nothing, try running a simple command and see what reaction you will get. – MelBurslan Jun 24 '16 at 15:56
  • 2
    I've seen this happen when the MTU is set lower on one of the internet connections. I would try setting the MTU to somewhere in the low 1400's on the actual NIC to see if that fixes it. Info on how to adjust MTU here. – Zachary Brady Jun 24 '16 at 17:38
  • 1
    MPU? Did you mean MTU? That's indeed a possibility, see if your symptoms match: unix.stackexchange.com/questions/124946/… – Gilles 'SO- stop being evil' Jun 24 '16 at 22:34
  • 1
    Start ssh with 1 or more -v options. – waltinator Jun 25 '16 at 16:24

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.