5

My problem is this:

While I'm typing on my XPS13 9350, it often happens that I touch the touchpad with my palm, causing the cursor to jump around and therefore I'm typing in the wrong place from then on.

What I've already tried:

  • Turning Palm detection on in /etc/X11/xorg.conf.d/touchpad.conf
  • Using syndaemon -i 2
  • Using synclient to turn off the touchpad alltogether
  • Using cinnamon settings to disable the touchpad while typing

All of these actions had absolutely no effect at all.

Best case would be one of these 2:

  • I can use the touchpad to move the cursor while I'm typing but I can't click

  • Palm detect works and the touchpad doesn't even notice anything because it detects my palm correctly

Also acceptable would be:

  • As long as I'm typing the touchpad is being disabled completely

Why has nothing I've tried so far had any effect and how can I get this to work?

2

2 Answers 2

6

The key to disable touchpad while typing doesn't exist anymore in the Gnome registry.

First install dconf-editor -

sudo dnf install dconf-editor

then create a key in dconf editor using this command on terminal.

dconf write /org/gnome/desktop/peripherals/touchpad/disable-while-typing true

It will create disable-while-typing as key and will set it to true.

This worked for me on fedora 23, Gnome 3.18. I will also work on fedora 24.

Update: Tested and this also works on Fedora 24,33.

3
  • this disables the trackpad but trackpad buttons are still alive :-(
    – lrkwz
    Aug 23, 2018 at 10:50
  • I guess, trackpad button can not be pressed accidentally while typing without knowingly putting enough pressure on it. :-)
    – Om Prakash
    Aug 23, 2018 at 11:39
  • This worked for me on Fedora 33
    – phhu
    Feb 22, 2021 at 9:18
2

http://ubuntuforums.org/showthread.php?t=2316240

Aswer is here. Problem is that somehow a generic touchpad is detected even though a different touchpad is actually in use. All the commands I tried went to the generic touchpad which doesn't actually exist, so that's why nothings worked.

Tried the fix and now it's all good.

1
  • Thanks! A couple of years later and this answer is still awesome :)
    – Jeremy
    Apr 24, 2018 at 5:34

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .