4

After some updates to the kernel, my laptop doesn't resume anymore if it's not connected to a power source. If I plug in the AC and then suspend, it will resume.

I thought that this was related to TLP and power management, but even disabling TLP doesn't make it resume on battery. In journal I just see:

Jun 23 08:19:01 miki-laptop systemd-logind[395]: Lid closed.
Jun 23 08:19:14 miki-laptop systemd-logind[395]: Suspending...
Jun 23 08:19:15 miki-laptop systemd[1]: Starting Lock X session using xlock...
Jun 23 08:19:15 miki-laptop systemd[1]: Starting TLP suspend/resume...
Jun 23 08:19:15 miki-laptop systemd[1]: Started TLP suspend/resume.
Jun 23 08:19:15 miki-laptop lock.sh[1107]: real        0m0.730s
Jun 23 08:19:15 miki-laptop lock.sh[1107]: user        0m0.690s
Jun 23 08:19:15 miki-laptop lock.sh[1107]: sys        0m0.017s
Jun 23 08:19:16 miki-laptop lock.sh[1107]: real        0m0.915s
Jun 23 08:19:16 miki-laptop lock.sh[1107]: user        0m0.857s
Jun 23 08:19:16 miki-laptop lock.sh[1107]: sys        0m0.030s
Jun 23 08:19:17 miki-laptop lock.sh[1107]: real        0m0.681s
Jun 23 08:19:17 miki-laptop lock.sh[1107]: user        0m0.767s
Jun 23 08:19:17 miki-laptop lock.sh[1107]: sys        0m0.010s
Jun 23 08:19:17 miki-laptop systemd[1]: Started Lock X session using xlock.
Jun 23 08:19:17 miki-laptop systemd[1]: Reached target Sleep.
Jun 23 08:19:17 miki-laptop systemd[1]: Starting Suspend...
-- Reboot --

The reboot is when I resume, so I don't really know if the problem lies in the suspend or in the resume. My laptop is an Asus UX305UA, and the problem is very similar to this other question: Asus UX303UA rebooting instead of resuming from suspend (ubuntu 15.10)

2

Looking into the BIOS options, I found "Wake on lid open". Even if it says "Enabled" it does not always work.

I found that when I upgrade the kernel, I have to go into the BIOS, select "Disabled", reboot, go into the BIOS again and select "Enabled".

Amazingly, with this process the laptop wakes from suspend on battery as well.

  • same on zenbook UX430 – Nick Feb 2 at 16:47
2

It's actually a Kernel Bug, see Kernel Bugtracker here: https://bugzilla.kernel.org/show_bug.cgi?id=108801

  • Is there a way to fix this? I use my laptop at college and open/close it a lot moving between classes, this is a major pain for me. I don't want to disable suspend on lid switch, because I might forget to manually suspend before I close the lid, and I don't want to have to remember in the first place. – Christopher Dumas Dec 4 '18 at 18:19
1

I had similar problem. Everything was fine but suddenly, when I suspended my laptop (buy closing the lid or via menu), it was going to sleep mode with led blinking, but when I woke the laptop, it restarted as it was shutdown.

Laptop ASUS ZenBook UX305

Linux 4.13.0-38-generic #43~16.04.1-Ubuntu SMP x86_64

I tried many things, and no result, but one time I switch to TTY1 with Ctrl+Alt+F1 and logged in, and exited. After that it is working again.

Also I set the following setting in "sudo vim /etc/default/grub" :

GRUB_CMDLINE_LINUX_DEFAULT="quiet splash acpi_sleep=nonvs intel_pstate=disable"

but it was not working before TTY1.

The things that was changing before the problem was :

  • I forgot my charger, and I used a different charger, the original is 19 volts but the one I used was 20 volts.
  • One time the laptop hanged during suspend process, so I did hard restart by pressing and holding the power button.
  • Recently, I updated the system with "Software Updater"

I thought it might help some one.

  • 1
    I think the consensus is that the problem arises after a forced shutdown with the power button. But as for solving it, nobody agrees. It's likely to be a BIOS problem. – rubik Apr 7 '18 at 12:29
0

I had the same problem with my UX305. The problem seems to be a problem of the ASUS BIOS not a kernel bug. The problem appears in Linux and in Windows. There is at the moment no fixed BIOS available. But the "solution"/workaround is to shutdown the UX305 (not reboot, only a clean shutdown and afterwards a new startup). After that resuming will work properly.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.