I've installed fedora 23 xfce desktop on my laptop few days ago and it worked like a beauty.

After few days i did sudo dnf update. after the update i couldn't change the wallpaper so i restarted my laptop, and after booting up i get two option.. One for the previous kernel and one for the updated one. I tried booth but it keeps taking to a black screen with nothing but a blinking underscore (-).

I can hit e to edit the booting thing and add a 3 somewhere to get to the terminal. I tried downgrading xorg-x11-server-Xorg but it didn't fix the issue.


I tried starting x from the terminal using startx and this is what i got.

xauth: file /home........./.serverauth.2093 does not exist.
xauth: (stdin):2 unknown command "some random characters"

X.Org X Server 1.18.3
Bunch of info about xorg and my machine

Parse on line 2 of section InputClass in file /etc/X11/xorg.conf .d/70-synaptics.conf
   "..." Is not a valid keyword in this section.

EE fatal server erro
EE no screen found(EE)

xinit: giving up
xinit: unable to connect to X server: connection refused
xinit: server error
[Ali@Almoullim ~]$ _

I edit this file in nano /etc/X11/xorg.conf .d/70-synaptics.conf and removed what was inside and now i get.


xauth: file /home........./.serverauth.2277 does not exist.
xauth: (stdin):2 unknown command "some random characters"

X.Org X Server 1.18.3
Bunch of info about xorg and my machine

Waiting for X server to shut down (II) Server terminated successfully (0). Closing log file.
[Ali@Almoullim ~]$ _

refer this is the log:

Update 2

I removed xorg conf.d directory and started X from the previous kernel and now i can get to the login screen but i cant use either my keyboard nor my mouse.

I believe there is something about that in the log file, see this part:

I'm guessing it says that it cant find the appropriate drivers for keyboard, mouse, wifi, ...etc

So i installed xorg-x11-drv-evdev && xorg-x11-drv-synaptics to enable the keyboard, mouse, and touchpad.

But some errors is still happening its taking startx about 1-2 min to start!!

Update 3

I just installed fedora on my second laptop but this time fedora 24. And surprisingly it took 3 min to get to i3!!

Guess the issue is with fedora then... I don't feel like trying to fix this anymore and i don't like using old version of fedora... I'm going back to Arch!

PS: i have a Lenovo Z500 i7 with 8gb ram and nvidia geforce 740m (its just not possible that my laptop is too weak to handle fedora)

  • have you tried recreate the xorg.conf or reinstalling the x11?
    – AReddy
    Jun 23, 2016 at 5:52
  • @Mongrel i did recreated the config file Jun 23, 2016 at 7:16
  • @Mongrel i just reinstalled xorg but its still taking too long to start Jun 23, 2016 at 7:25

2 Answers 2


Not sure, but what you are describing sounds a bit like a recent issue that the system would fail to load X (i.e., a graphical desktop) most of the time, except sometimes after several minutes.

You should check if it also happens with the Fedora 24 live system, without installing anything.

If it is that issue, the following boot option might help:


(As usual, in the boot menu hit E, and append it to the "linux" line.)


I had a similar issue. Turns out that it is not due to upgrade but it was because i had declared environment variables in /etc/environment file like i used to do it with ubuntu. Removing those variables fixed the issue.

How to fix: On fedora login screen, press ctrl+Alt+F2 and to go to terminal. Use vi editor to edit the file. You may have to give full path of the command like /usr/bin/sudo /usr/bin/vi /etc/environment to edit the file. Remove all entries which you have added. Do not remove system added entries !

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.