3

Problem:

I'm trying to install Debian 8.5 Linux (amd64 netinstall from USB) on a Fujitsu Lifebook P701, but after I select "Install" (or "Graphical Install", or anything else) from grub, I get corrupted screen - black with some blinking pixels at the top. But I think it's really only a display issue, because:

  • caps lock, num lock works (leds change)
  • alt-F1, alt-F2 (or ctrl-alt-F1 in Graphical Install) causes blinking pixels at the top of the screen to change (different "pattern" for each virtual console)
  • I was able to proceed with "Install using speech synthesis" (but only for a while - it's hard to understand and I don't want to break something so I stopped at disk partitioning)

I tried ubuntu installer and it works without any problems, but I do not want ubuntu, I want debian.

What I tried:

  • switching grub to textmode - grub command: text_output console
  • editing linux .../vmlinuz vga=788 --- quiet to

    • ../vmlinuz vga=normal fb=false
    • ../vmlinuz text nofb
    • ../vmlinuz nomodeset

    and many other variants

  • CD installer, DVD installer

It all resulted in black screen with random pixels at the top. And sometimes (grub console text mode) "Booting a command list" text partialy covered at the top with the random pixels.

Question

Is there some way to use only text mode for both grub and kernel? Or is there any way to install without screen? The laptop has no serial port, so no serial console, but perhaps using USB port or network?

HW:

Fujitsu LifeBook P701, Intel Core i5-2520M, 4GB RAM, Intel HD Graphics 3000

  • What happens if you connect an external monitor? – Vlastimil Jun 23 '16 at 9:35
  • @burian.vlastimil it's all the same - only the random pixels are at the top of a smaller rectangle... – Jan Spurny Jun 23 '16 at 12:03
2

I was finally able to install debian on the laptop - I manually created bootable USB stick with syslinux (which has textmode by default) and since that process was far more complicated than I originaly thought, I'm posting it here:

I was using instructions from:

This is how I did it:

On my "normal" computer:

  1. download $ wget http://cdimage.debian.org/debian-cd/8.5.0/amd64/iso-cd/debian-8.5.0-amd64-netinst.iso
  2. insert USB-stick (used $ dmesg | tail to determine device name - /dev/sde - but you'll probably get a different name, so I'll use sdX)
  3. $ sudo cfdisk /dev/sdX - create one big FAT16 bootable (!) partition /dev/sdX1
  4. make filesystem: $ sudo mkdosfs /dev/sdX1
  5. make USB-stick bootable: $ install-mbr /dev/sdX
  6. install syslinux: $ sudo syslinux /dev/sdX1
  7. mount the stick: $ sudo mount /dev/sdX1 /mnt
  8. copy vmlinuz and initrd.gz from iso to /mnt
  9. create /mnt/syslinux.cfg with the following content:

    default vmlinuz initrd=initrd.gz
    
  10. now the manuals above says to "copy iso image to USB stick" - which is what I probably didn't get right - I tried to copy the content of the ISO, the ISO file itself, but I ended up with the iso file copied as netinst.iso to /mnt

  11. $ sudo umount /mnt

On the laptop

  1. insert the stick, power up laptop
  2. linux boots quite nicely in textmode
  3. the install process starts but it ends up with Incorrect CD-ROM detected error.
  4. I tried to mount usb stick to /mnt and then mount /mnt/netinst.iso to /cdrom which didn't worked - so I just copied the content of the ISO file (do not forget the .disk hidden directory!) to another USB disk (on my "normal" computer), inserted it in the laptop, mount it in a console as a cdrom (ALT-F2, enter): mount /dev/sdc1 /cdrom
  5. then I went back to main console (ALT-F1) and install process was resumed and I was able to finish installing with one small glitch:

    • when debian installer was about to configure apt-sources mirrors, it was not able to do this - no crash, just a window flashed on the screen and I was in the install menu (D-I) - I found out here: http://www.mail-archive.com/debian-live@lists.debian.org/msg07251.html that the problem was with the /usr/lib/apt-setup/generators/50mirror file, a db_metaget apt-setup/use/netinst description line to be specific. I finally just deleted the line from 2nd console (ALT-F2) using nano editor:

      $ nano /usr/lib/apt-setup/generators/50mirror
      
    • then I just had to run every subsequent task from the D-I menu manually, but no other problem was encountered and I'm quite happy with the nice little laptop.
0

I got the same issue on a Lenovo Yoga 11S and all linux command line parameters mentionned doesn't work either.

Finally, I get this installer working by changing the BIOS parameter...
I modify the boot mode from "Legacy" to "UEFI" and the screen displays correctly in both text mode or graphical mode.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.