0

fedora-3 (I know, it is ancient, but this is my sandbox where I look under the hood), udev-039, kernel 2.6.27, configured and compiled by myself. I'm using pci wifi card with ath9k module. Kudzu recognizes hardware, assigns eth1 interface, but device is missing. dmesg shows ath9k: 0,1 - looks like no warning. /sys directory does show details on bus. Tried adding udev rules file with reference to vendor and product id but still cannot activate device. Any ideas on what is going on or how to fix it?

F.Y.I. booting same box into ubuntu 14.04 card and wifi is working.

  • What is the output of ip link show? – Zachary Brady Jun 22 '16 at 16:49
  • Why not replace the ancient distro on your sandbox with one that has been maintained the past 10 years? I really don't see any sensible reason to invest time into such a problem. – Martin von Wittich Jun 22 '16 at 20:32
  • @ZacharyBrady very similar to output of ifconfig, showing only interfaces lo and eth0 'code'1: lo: <LOOPBACK,UP,10000> mtu 16436 qdisc noqueue link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00 2: eth0: <BROADCAST,MULTICAST,UP,10000> mtu 1500 qdisc pfifo_fast qlen 1000 link/ether 00:e0:18:ed:a7:3e brd ff:ff:ff:ff:ff:ff – Janos Jun 24 '16 at 1:29
  • Look into using backports but that may not work if you don't have kernel headers or the necessary packages to built kernel modules – Jeremy31 Jun 25 '16 at 15:55
  • @jeremy31 - I do not understand "backport" or "building kernel modules". I have compiled kernel 2.6.27 and configured it to build ath9k as a module. I'm running the fc3 boot with 2.6.27 kernel. It does load ath9k module and /sys does recognize the bus and the card. If I knew more about linux and c I would suspect that udev is unable to create device corresponding to the wifi card that has the ath9k driver. – Janos Jun 27 '16 at 2:31
0

The root cause was that initial release of ath9k driver in kernel-2.6.27 had limited chipset support. Kernel-2.6.32 has support for the AR9227 chip in TP-LINK TL-WN851ND PCI card. Credit for the solution goes to @jeremy31 who suspected that the installed ath9k driver may not support the actual chipset. What I have learned is that even if module installs without error and even if dmesg signals no error things may still not work as intended. - Yes, old machine, old linux, but good education. Thanks again, Zachary Brady and Jeremy31

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.