1

I'm using the official documentation for quick-start to install Atomic Registry on a Centos 7 atomic host, and it appears I can't access anything on port 443. (I also tried with a Fedora 23 atomic host, but, with about the same results)

Here's my system info

[centos@atomic1 ~]$ uname -a
Linux atomic1.localdomain 3.10.0-327.13.1.el7.x86_64 #1 SMP Thu Mar 31 16:04:38 UTC 2016 x86_64 x86_64 x86_64 GNU/Linux
[centos@atomic1 ~]$ cat /etc/redhat-release 
CentOS Linux release 7.2.1511 (Core) 

Here's the steps I took, other than the official documentation, the only added step I took was to disable selinux.

[centos@atomic1 ~]$ sudo atomic install projectatomic/atomic-registry-quickstart 192.168.122.161
[centos@atomic1 ~]$ sudo atomic run projectatomic/atomic-registry-quickstart 192.168.122.161

I've posted the details of the install & run commands here at pasteall.

I've also taken a look at the docker logs for the origin container, e.g. sudo docker logs origin and I've posted those logs as well.

I'm not well versed in Kubernetes, but I don't see the docker containers listening on any ports

[centos@atomic1 ~]$ sudo docker ps
CONTAINER ID        IMAGE                                     COMMAND                  CREATED             STATUS              PORTS               NAMES
7c55fe09fda7        cockpit/kubernetes                        "/usr/libexec/cockpit"   2 minutes ago       Up 2 minutes                            k8s_registry-console.e1e1af45_registry-console-1-cyrbk_default_a2d0a2a3-37a8-11e6-b418-525400f177e5_76e30266
ff7c6af11175        openshift/origin-docker-registry:latest   "/bin/sh -c 'DOCKER_R"   2 minutes ago       Up 2 minutes                            k8s_registry.3b6c8c75_docker-registry-1-5kva8_default_a2b1914e-37a8-11e6-b418-525400f177e5_e68c9f03
6f028b08118a        openshift/origin-pod:v1.3.0-alpha.1       "/pod"                   2 minutes ago       Up 2 minutes                            k8s_POD.f8600130_registry-console-1-cyrbk_default_a2d0a2a3-37a8-11e6-b418-525400f177e5_b1982d98
ca1114728493        openshift/origin-pod:v1.3.0-alpha.1       "/pod"                   2 minutes ago       Up 2 minutes                            k8s_POD.dfaa0123_docker-registry-1-5kva8_default_a2b1914e-37a8-11e6-b418-525400f177e5_739d21b2
21808267a1a1        openshift/origin                          "/usr/bin/openshift s"   5 minutes ago       Up 5 minutes                            origin

Nor do I see any ports with netstat, a la:

[centos@atomic1 ~]$ netstat -atl | grep 443

And when I try to curl the local IP (and IP address I specified in the atomic install and atomic run commands), I get a connection refused

[centos@atomic1 ~]$ curl -k -v https://192.168.122.161
* About to connect() to 192.168.122.161 port 443 (#0)
*   Trying 192.168.122.161...
* Connection refused
* Failed connect to 192.168.122.161:443; Connection refused
* Closing connection 0
curl: (7) Failed connect to 192.168.122.161:443; Connection refused

Which makes sense, seeing that it doesn't look like there's anything listening on 443.

So I went ahead and entered the origin container, and looked at the pods and the logs of a pod per this extra administrative document about continuing the configuration of atomic registry, but, unfortunately I'm not sure what to do next.

[root@atomic1 origin]# oc get pods
NAME                       READY     STATUS    RESTARTS   AGE
docker-registry-1-5kva8    1/1       Running   0          15m
registry-console-1-cyrbk   1/1       Running   0          15m
[root@atomic1 origin]# oc logs registry-console-1-cyrbk
INFO: cockpit-ws: Using certificate: /etc/cockpit/ws-certs.d/0-self-signed.cert

1 Answer 1

0

Turns out that just yesterday Project Atomic announced that there's a method to install using systemd.

I followed that method, using the instructions from this openshift/origin project example about atomic registry.

Here's the snippet from that README.md that worked at the time of authoring this example:


Installation

  1. Install

    sudo atomic install projectatomic/atomic-registry-install <hostname>
    
  2. Start system services

    sudo systemctl start atomic-registry-master.service
    
  3. Setup the registry. This script creates the oauth client so the web console can connect. It also configures the registry service account so it can connect to the API master.

    sudo /var/run/setup-atomic-registry.sh <hostname>
    
1
  • I installed the registry using the above method. when I access the console I get redirected to the Oauth server but after the redirect the registry console displays "Authentication failed" message.
    – Chamindu
    May 9, 2017 at 11:42

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .