4

X11 has been relatively sane on my Arch install until recently. It behaves normally in most programs, but as of maybe a week ago, if anything tries to run fullscreen it will only update when my mouse moves. For example, screensavers and youtube videos (Firefox) only work when my mouse is moving, somewhat defeating the purpose of both.

This issue occurs both under GNOME and in a naked X.org session running without a window manager.

Unforunately I've been unable to find anyone else with this or a similar problem through Google, but I very well may have been using poor search terms.

  • Start by finding the X11 properties for the window. You can achieve that by using xprop and/or xwininfo. Recent versions of both (xprop and xwininfo) allow you to use the mouse pointer to select the window. – grochmal Jun 20 '16 at 20:17
  • 2
    What exact model of graphics card do you have? What driver do you use? – Gilles 'SO- stop being evil' Jun 20 '16 at 22:51
4

For me it worked to set the acceleration method of my intel driver to uxa.

By creating /etc/X11/xorg.conf.d/20-intel.conf With the contents:

Section "Device"
   Identifier  "Intel Graphics"
   Driver      "intel"
   Option      "AccelMethod"  "uxa"
EndSection

I got this from here. It was bugging my VirtualBox but also my Firefox.

You can also check this. Maybe it applies to you.

| improve this answer | |
  • Is there any way to do this in a live linux? I obviously cannot reboot it. – Kurtibert Apr 26 at 11:47

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.