1

This question already has an answer here:

When I download anything using Google Chrome or Mozilla Firefox and I use the "Show in folder" option (or "Open Containing Folder" in case of Firefox) it does not work correctly, instead, it open the directory with my text editor Atom...

What I can do to make it work properly?

PS: My OS is Elementary.

marked as duplicate by sam, mdpc, Dmitry Grigoryev, Kusalananda, don_crissti Jan 12 '17 at 21:32

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

  • what is your default file manager ? could you run "nautilus" command in terminal – Mustafa DOGRU Oct 27 '16 at 12:32
1

This happened to me even in other programs like uGet, a downloader that also has the option "open containing folder".

The problem is, as indicated here triggered by the certain programs.

The best solution is to create or edit ~/.local/share/applications/mimeapps.list: edit the line that starts with inode/directory= and add the name of the file manager that you use if it is not there already; if that is already there but another program is listed there first, put the file manager first (if you need the other program(s) to open folders).

For Pantheon Files it should be like

[Default Applications]
inode/directory=org.pantheon.files.desktop; 

If the desktop environment is not freedesktop complient, like my Manjaro Cinnamon, the file to be created/edited should be ~/.local/share/applications/mimeinfo.cache like so:

[MIME Cache]
inode/directory=org.pantheon.files.desktop; 

You should post elementaryOS questions on its own stackexchange site: https://elementaryos.stackexchange.com/

Not the answer you're looking for? Browse other questions tagged or ask your own question.