1

I have been trying to update Gallium OS (which is based on Ubuntu), however, I keep on getting error messages. Any help would be appreciated. Please see a screenshot of the error message below:

Error message.

I ran sudo apt-get -f install in terminal and received the following message:

Reading package lists... Done
Building dependency tree       
Reading state information... Done
Correcting dependencies... Done
The following extra packages will be installed:
  libssl1.0.0:i386
The following packages will be upgraded:
  libssl1.0.0:i386
1 upgraded, 0 newly installed, 0 to remove and 1 not upgraded.
3 not fully installed or removed.
Need to get 0 B/1,106 kB of archives.
After this operation, 0 B of additional disk space will be used.
Do you want to continue? [Y/n] y
Preconfiguring packages ...
(Reading database ... 193560 files and directories currently installed.)
Preparing to unpack .../libssl1.0.0_1.0.2d-0ubuntu1.5-galliumos0_i386.deb ...
Unpacking libssl1.0.0:i386 (1.0.2d-0ubuntu1.5-galliumos0) over (1.0.2d-0ubuntu1.4-galliumos0) ...
dpkg: error processing archive /var/cache/apt/archives/libssl1.0.0_1.0.2d-0ubuntu1.5-galliumos0_i386.deb (--unpack):
 trying to overwrite shared '/usr/share/doc/libssl1.0.0/changelog.Debian.gz', which is different from other instances of package libssl1.0.0:i386
dpkg-deb: error: subprocess paste was killed by signal (Broken pipe)
Errors were encountered while processing:
 /var/cache/apt/archives/libssl1.0.0_1.0.2d-0ubuntu1.5-galliumos0_i386.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)
  • try sudo apt-get -f install to force an install of the files that didn't get loaded because of the error. – Rahul Jun 20 '16 at 6:50
  • I've actually tried that before. This is the response that I get: dpkg: error processing archive /var/cache/apt/archives/libssl1.0.0_1.0.2d-0ubuntu1.5-galliumos0_i386.deb (--unpack): trying to overwrite shared '/usr/share/doc/libssl1.0.0/changelog.Debian.gz', which is different from other instances of package libssl1.0.0:i386 dpkg-deb: error: subprocess paste was killed by signal (Broken pipe) Errors were encountered while processing: /var/cache/apt/archives/libssl1.0.0_1.0.2d-0ubuntu1.5-galliumos0_i386.deb E: Sub-process /usr/bin/dpkg returned an error code (1) – Mahdi B. Jun 20 '16 at 6:58
  • Sorry if that looks a bit jumbled together. – Mahdi B. Jun 20 '16 at 6:59
  • please edit your post and paste content requested by any user. this will help others too. – Rahul Jun 20 '16 at 7:00
  • Ah, I wasn't aware that's how I was supposed to respond. Just updated the post. Thanks. – Mahdi B. Jun 20 '16 at 7:09
0

Possible workaround would be to rename that directory, and force installation like this,

sudo mv /usr/share/doc/libssl1.0.0 /usr/share/doc/libssl1.0.0.backup
sudo apt-get -f install

Or this might also fix your problem,

apt-get install libssl1.0.0 libssl1.0.0:i386
  • specifying architectures (i386 and amd64) to have the same version of package could have fix your problem. – Rahul Jun 20 '16 at 7:25

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.