2016-06-19 - Initial Post

I'm having trouble setting up my wifi connection on GoboLinux. I already installed the propietary broadcom drivers. The wifi module is now recognized, at least.

Using iwconfig wlan0 gives me the following output:

wlan0     IEEE 802.11bg  ESSID:off/any
          Mode:Managed  Access Point: Not-Associated   Tx-Power=20 dBm
          Retry short limit:7   RTS thr:off   Fragment thr:off
          Power Management:off

That means there must be some kind of wifi module build into my laptop. (Using Windows it works btw.)

lspci -k shows me the name of the Network controller.

04:00.0 Network controller: Broadcom Corporation BCM4312 802.11b/g LP-PHY (rev 01)
    Subsystem: Broadcom Corporation Device 04b5
    Kernel driver in use: b43-pci-bridge
    Kernel modules: ssb

The firmware is being loaded - dmesg | grep b43:

[    8.127113] b43-phy0: Broadcom 4312 WLAN found (core revision 15)
[    8.142216] b43-phy0: Found PHY: Analog 6, Type 5 (LP), Revision 1
[ 1339.940316] b43-phy0: Loading firmware version 666.2 (2011-02-23 01:15:07)
[ 1777.008290] b43-phy0: Radio hardware status changed to DISABLED
[ 1782.025291] b43-phy0: Radio hardware status changed to ENABLED
[ 2247.468296] b43-phy0: Loading firmware version 666.2 (2011-02-23 01:15:07)

I am not able to scan for existing wifi networks and also cannot connect to one. What am I missing?

2016-06-20 - Edit, Print System Information

Here is my System Information per uname -a:

Linux Arbeits-PC 3.14.2-Gobo #1 SMP PREEMPT Sat May 3 22:59:40 GMT 2014 i686 GNU/Linux
  • Please add the output of uname -a – GAD3R Jun 19 '16 at 21:36
  • I added the System Information (uname -a) – tlp Jun 20 '16 at 17:09

The bcm4312 is supported by the b43 driver.

Install the firmware-b43-lpphy-installer package .

Unload driver:

modprobe -r b43-pci-bridge
modprobe -r ssb

Load the b43 driver :

modprobe b43
| improve this answer | |
  • i installed it via recipe, but i still cannot find any network. – tlp Jun 22 '16 at 16:46

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.