26

I'm running old Debian machine: Distributor ID: Debian Description: Debian GNU/Linux 5.0.2 (lenny) Release: 5.0.2 Codename: lenny

I open terminal and run Midnight Commander in it. Now I need to quit by pressing F10. But When I do this I'm getting terminal menu:

enter image description here

How to get MC menu and not terminal one by pressing F10?

1

3 Answers 3

25

Go to Edit->Keyboard Shortcuts

And uncheck "Enable the menu shortcut key"

to turn it off.

Reference link : here.

2
  • 13
    Ubuntu 18.04 edit->preferences->general (uncheck) enable the menu accelerator key (F10 by default)
    – vic-3
    Nov 23, 2018 at 14:33
  • Now F10 no longer works in allow application to receive that F10 keystroke value. Debian 11, Gnome-Terminal 3.30.2 Apr 9, 2020 at 15:50
13

On Ubuntu 20.04.1, Gnome version 3.36.8 it is:

Gnome terminal's "hamburger menu icon"
  > Preferences
    > "General" tab
      > Uncheck the item labeled "Enable the menu accelerator key (F10 by default)"

Just a remark: on the same system, a dconf / gsettings setting exists:

/org/gnome/terminal/legacy/ shortcuts-enabled

Its default value is true. Currently it does not seem to impact / conflict with the choice made in the terminal preferences UI. Nevertheless I believe it may be useful to remain mindful of its existence... Just in case one day it may start to interfere again ;)

1
  • worked on Ubuntu 22.04.2 LTS, Gnome 42.5 as well Mar 24, 2023 at 15:30
4

The best way I found in gnome 4 on a Fedora 35 to disable F10 shortcut :

gsettings set org.gnome.Terminal.Legacy.Settings menu-accelerator-enabled false

Hope it helps :)

Not the answer you're looking for? Browse other questions tagged .