2

scl is installed on RedHat 6. The man pages for scl work. I want to install Django. I believe that a prerequisite is to install SCL for Python.

$scl -l 

returns nothing. I believe that this is a problem. But I don't know what I did wrong.

python --version  

returns Python 2.7.5

I ran this command:

scl enable python27 bash

It returned this:

Unable to open /etc/scl/conf/python27!

I tried scl enable python275 bash too. How do I get to enable Python 2.7 with scl? I believe I'll have problems with installing Django based on the directions that I read. There are no files in /etc/scl/conf/. What should I do to get Django installed?

Update (6/24/16): When I tried to run this sudo yum install python27

I received this:

Error: Package: python27-python-libs-2.7.5-10.el6.x86_64 (scl_python27) Requires: libffi.so.5()(64bit) Error: Package: python27-python-libs-2.7.5-10.el6.x86_64 (scl_python27) Requires: libgdbm.so.2()(64bit) You could try using --skip-broken to work around the problem

I tried to install the relevant RPMs. I got a message that a newer version was already installed. I'd rather not downgrade Python from 2.7.5 to 2.7.3.

I tried skip-broken (with sudo yum install python27), but I received this:

Packages skipped because of dependency problems:

compat-db-headers-4.7.25-28.el7.noarch from rhui-REGION-rhel-server-releases compat-db47-4.7.25-28.el7.x86_64 from rhui-REGION-rhel-server-releases python27-1.1-15.el6.x86_64 from scl_python27 python27-python-2.7.5-10.el6.x86_64 from scl_python27 python27-python-babel-0.9.6-7.el6.noarch from scl_python27 python27-python-devel-2.7.5-10.el6.x86_64 from scl_python27 python27-python-docutils-0.11-1.el6.noarch from scl_python27 python27-python-jinja2-2.6-9.el6.noarch from scl_python27 python27-python-libs-2.7.5-10.el6.x86_64 from scl_python27 python27-python-markupsafe-0.11-11.el6.x86_64 from scl_python27 python27-python-nose-1.3.0-1.el6.noarch from scl_python27 python27-python-pygments-1.5-2.el6.noarch from scl_python27 python27-python-setuptools-0.9.8-1.el6.noarch from scl_python27 python27-python-simplejson-3.2.0-1.el6.x86_64 from scl_python27 python27-python-sphinx-1.1.3-7.el6.noarch from scl_python27 python27-python-sqlalchemy-0.7.9-3.el6.x86_64 from scl_python27 python27-python-virtualenv-1.10.1-2.el6.noarch from scl_python27 python27-python-werkzeug-0.8.3-5.el6.noarch from scl_python27 python27-runtime-1.1-15.el6.x86_64 from scl_python27

This command still returns nothing (no errors, just goes to the next prompt):

scl -l
  • Did you edit scl.repo as shown here? – Jedi Jun 19 '16 at 7:12
  • I tried. I ran this: "sudo yum install python27" and I received this: Loaded plugins: amazon-id, rhui-lb, search-disabled-repos Config error: File contains no section headers. file: file:///etc/yum.repos.d/scl.repo, line: 1 'c/p from people.redhat.com/bkabrda/scl_python27.repo\n' – Kiran Jun 24 '16 at 23:24
  • Or...you can use python virtualenv to create a separate installation of python in user's home directory. Then, you can do pip install django – ILMostro_7 Jan 31 '18 at 12:59

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.