2

I've got a Cubox-i4Pro running Debian Jessie hooked up to an external USB3/eSATA dual HDD dock (via eSATA). It originally only had one WD Green 2TB drive installed. Via UUID in fstab this auto mounted the drive at boot with absolutely 0 issues.

Well I finally got around to buying a WD Green 2TB to create a basic redundancy.

After finding the new drive's UUID and adding it to fstab, neither will mount during boot. But after boot, in the terminal emulator, I can run 'sudo mount -a' and it mounts both immediately.

Here is the fstab:

/dev/mmcblk0p1 / ext4 defaults,noatime,nodiratime,commit=600,errors=remount-ro 0 1
tmpfs /tmp tmpfs defaults,rw,nosuid 0 0
/var/swap none swap sw 0 0

# SATA1
UUID=08963297963284EA /mnt/sata1 ntfs rw,auto,users,exec,nls=utf8,umask=002,gid=1000,uid=1000    0   0

# SATA2
UUID=269613109612E05B /mnt/sata2 ntfs rw,auto,users,exec,nls=utf8,umask=002,gid=1000,uid=1000    0   0 

I've poured over dmesg looking for anything out of the ordinary, although I'm not entirely certain what I'm looking for.

  • 1
    I don't see the problem yet. However, my first question would be: why are the drives formatted to the NTFS filesystem? – LinuxSecurityFreak Jun 17 '16 at 18:21
  • The original drive came out of an old machine, with data and NTFS already present. I've considered using ext4 but wasn't sure if it'd create a buncha headaches. They are accessed by other windows machines locally and remotely via VPN – B Wulf Jun 17 '16 at 18:29
  • Ok, could you format the new drive with ext4, move the data from the existing drive there, then format the original drive with ext4 too and report if solved? – LinuxSecurityFreak Jun 17 '16 at 18:32
  • I suppose I could. But I'm more curious why adding another line to fstab is causing this. The setup worked fine with the original SATA1 line, quick boot and automatic mount. it just makes very little sense to me why adding another disk could be so catastrophic, unless its a restriction of the dock I'm using or something alone those lines – B Wulf Jun 17 '16 at 18:33
  • It has something to do with the bloody esata cable. The dock has both that and USB, so I tried the USB cable. It boots without issue. So there is something amiss either physically with the port/cable/dock, or the software doesn't truly support "port multiplier" like it claims to (I saw it mentioned in dmesg once or twice, v 1.1 or something along those lines). – B Wulf Jun 17 '16 at 19:17

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.