1

I am trying to make on-line steam games work on my laptop. I have this problem: games can't connect to game servers if I run them on linux. If I run them on Windows they work fine. Other Windows laptop on this network works fine too. If I run the game on linux but on another network it works fine too.

Currently I think that MTU is the problem.

$ ip link list
1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN mode DEFAULT group default qlen 1
    link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
2: enp1s0: <NO-CARRIER,BROADCAST,MULTICAST,UP> mtu 1500 qdisc fq_codel state DOWN mode DEFAULT group default qlen 1000
    link/ether 68:f7:28:24:00:3f brd ff:ff:ff:ff:ff:ff
3: wlp3s0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc mq state UP mode DORMANT group default qlen 1000
    link/ether ac:d1:b8:76:05:5b brd ff:ff:ff:ff:ff:ff


$ ping -M do -s 700 192.168.0.1
PING 192.168.0.1 (192.168.0.1) 700(728) bytes of data.
ping: local error: Message too long, mtu=576
ping: local error: Message too long, mtu=576
ping: local error: Message too long, mtu=576
^C
--- 192.168.0.1 ping statistics ---
3 packets transmitted, 0 received, +3 errors, 100% packet loss, time 2004ms

My question is why does the ping say mtu=576? From ip link list we can see that wlp3s0 has mtu 1500. Also, I've set router's MTU to 1492 according to ISP's information.

UPD. I've found out that 576 Typically recommended as the MTU for dial-up type applications, leaving 536 bytes of TCP data.

UPD 2 192.168.0.108 is my IP, 192.168.0.1 is my router's IP.

$ ip route show
default via 192.168.0.1 dev wlp3s0  src 192.168.0.108  metric 303  mtu 576
192.168.0.0/24 dev wlp3s0  proto kernel  scope link  src 192.168.0.108  metric 303  mtu 576

UPD 3 I've also tried to do ping google.com -f -l 1480 on a Windows 10 laptop in the same network. It worked as it should. Lengths less than ~1500 pass and more than ~1500 need fragmenting. So, the problem is on my end.

  • Maybe we should move this to Superuser? – imustafin Jun 16 '16 at 16:18
  • add ip route show output to your question please – Serge Jun 16 '16 at 16:28
  • @Serge oh there is mtu 576 too – imustafin Jun 16 '16 at 16:45
0

It is my first time with ip route but I did this:

ip route del all routes and then

ip route add default via 192.168.0.1 dev wlp3s0 mtu 1492

to add a default route through my router. I hope I didn't miss anything important.

  • Better check the settings at your router: if it provides the IP settings to your host by means of DHCP then there is some reason for such MTU. – Serge Jun 16 '16 at 21:49
  • I've set 1492 at my router according to ISP's instructions. I am using ADSL connection. Also, games are working great, so I think everything should be good. – imustafin Jun 17 '16 at 13:30

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.