1

My laptop is a Toshiba CB35-B3340. Also called a Chromebook 2, with part number PLM02U-009008. I had a working installation of Arch on it yesterday, but accidentally destroyed it while moving partitions around.

On the previous installation, this weird glyph-like text error would occur in the middle of boot, but would resolve itself at the login prompt and I would proceed. I had intended to get to the cause of it, but decided not to bother.

I am now dealing with this same issue. During boot, the glyph-like text error appears. Unlike before, it does not resolve itself automatically. Please see attached my four images that illustrate the boot sequence.

Note that I'm certain that I'm actually interfacing with the system. I can tell from what I'm putting into the console and the length of the output that I am indeed dealing with a simple working installation of Arch.

enter image description here Blurry: Normal text from the BIOS. I've installed SeaBIOS, as is necessary for chromebooks.

enter image description here Blurry: Getting the GRUB2 menu as normal. Arch Linux is the highlighted entry.

enter image description here Blurry: Nearing the end of the boot process. Then, right after Loading initial ramdisk,

enter image description here Fubar: Complete gibberish. This is the login prompt.

enter image description here Fubar: More gibberish. This is the output of uname -a after having logged in as root.

I have tried changing the font with setfont, and it does have an effect; I can set Goha-12, Goha-14, and Goha-16 and the difference will be the height. The glyphs, however, will remain.

  • Ah, the joy of cameras that do all of the adjustments automatically for you, and end up bringing your reflected head into focus at the expense of blurring the screen! And from that, the challenge to the world of identifying already mysterious glyphs from images that are out of focus. – JdeBP Jun 16 '16 at 6:35
  • To save other people's eyes: This is not a mystery font. This is the questioner's ordinary font, with the glyphs printed in mirror image form, overprinted multiple times, with each instance shifted left by a pixel. – JdeBP Jun 16 '16 at 6:54
  • @JdeBP I agree that it's a pain to read the first three images' text, and yes, you can see me in the screen. I did try a multitude of times to get the camera to focus correctly, but was unable, and as an added precaution I did annotate each one of the images to help distinguish what was and was not the garbled font in question. I appreciate that you seem to be able to tease how each character has been transformed. The problem remains, however-- why is it happening, and how would I stop it? – jwarner112 Jun 16 '16 at 19:11
  • See also unix.stackexchange.com/q/304771/5132 which appears to be similar. – JdeBP Aug 21 '16 at 12:15
1

old question, I know but I just solved a very similar issue and someone linked me here. You can find my question here.

My solution was:

In /etc/default/grub:

Comment out GRUB_CMDLINE_LINUX_DEFAULT="splash quiet" entirely.

Uncomment GRUB_TERMINAL=console

Uncomment GRUB_GFXMODE=640x480. I set it to GRUB_GFXMODE=1280x800 because that's the monitor I'm using's default.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.