1

Freshly installed Debian 8 on a Dell XPS - Developer Edition laptop, and running the 3.16.0-4 kernel since the newer one doesn't boot (dont care to fix that at the moment).

sudo lspci -nnk | grep -iA2 net lists the following:

3a:00.0 Network controller [0280]: Intel Corporation Wireless 8260 [8086:24f3] (rev 3a)
        Subsystem: Intel Corporation Device [8086:0050]
3b:00.0 Unassigned class [ff00]: Realtek Semiconductor Co., Ltd. Device [10ec:525a] (rev 01)

I downloaded the firmware (tried both iwlwifi-8000C-13.ucode and iwlwifi-8000C-17.ucode) and copied it to /lib/firmware, rebooted and nothing changed.

If I try to install using apt-get install firmware-iwlwifi, my USB-ethernet adapter stops working as well.


Edit: Also, my driver (8000-17.ucode) isn't even listed in the firmware-iwlwifi packed here:

https://packages.debian.org/search?keywords=firmware-iwlwifi


errors when trying make menuconfig

root@001:/linux-4.1.26#
  HOSTCC scripts/kconfig/mconf.o
In file included from scripts/kconfig/mconf.c:23:0:
scripts/kconfig/lxdialog/dialog.h:38:20: fatal error: curses.h: No such file or directory

#include CURSES_LOC
                   ^
compilation terminated.
scripts/Makefile.host:108: recipe for target 'scripts/kconfig/mconf.o' failed
make[1]: *** [scripts/kconfig/mconf.o] Error 1
Makefile:541: recipe for target 'menuconfig' failed
make: *** [menuconfig] Error 2
2
  • Are you trying to load the iwlwifi module: modprobe iwlwifi ?
    – GAD3R
    Commented Jun 15, 2016 at 19:47
  • What firmware is iwlwifi looking for on your system? It should tell you the specific file name in the kernel logs. Commented Jun 16, 2016 at 7:19

1 Answer 1

1

According to Linux* Support for Intel® Wi-Fi Adapters the Intel 8260 is only suppoted by the 4.1 Kernel version:

Download and build the 4.1.26 kernel.

Use the iwlwifi-8000-ucode-25.30.13.0.tgz driver

5
  • 2
    The problem is the iwlwifi module is loadable only for a specific kernel version 4.1 .
    – GAD3R
    Commented Jun 15, 2016 at 20:31
  • downloaded the 4.1.26.tar.xz from kernel.org, but i keep getting errors when I try to run make menuconfig Commented Jun 16, 2016 at 14:16
  • added errors to the main post Commented Jun 16, 2016 at 14:23
  • Run apt-get install build-essential libncurses5-dev libncursesw5-dev
    – GAD3R
    Commented Jun 16, 2016 at 14:49
  • 1
    Worked perfectly after getting the other 4.5 kernel errors out of the way, thanks! Commented Jun 16, 2016 at 15:48

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .