I am trying from last few hours, I want to install wine on kali rolling.

My source.list has only 1 entry:

deb http://http.kali.org /kali kali-rolling main contrib non-free

I tried every possible ways following by kali fourms, and others websites, but not success till now.

Few looks on my tries:

apt-get install wine
dpkg --add-architecture i386 
apt-get update
apt-get install wine-bin:i386

Error I get from the last command:

Reading package lists... Done
Building dependency tree 
Reading state information... Done
E: Unable to locate package wine-bin:i386

Can anyone help me to successfully install wine on rolling?

I am using 32bit, fresh install of kali.

I also tried again after performing an update:

apt-get update
apt-get dist-upgrade

2 Answers 2


Try http://www.tecmint.com/install-wine-in-linux/, it worked for me.

On Debian systems, you should follow below instructions to install latest WineHQ development builds.

First, enable 32-bit packages, then download and install key which is used to sign packages.

$ sudo dpkg --add-architecture i386
$ wget https://dl.winehq.org/wine-builds/Release.key
$ sudo apt-key add Release.key

Next place the repository to /etc/apt/sources.list file with the following content at the bottom:

deb https://dl.winehq.org/wine-builds/debian/ DISTRO main

Note: Don’t forget replace DISTRO with your Debian release either wheezy, jessie, stretch or sid.

Debian Wheezy users also need to add the following line to /etc/apt/sources.list file to avoid any issues with missing software dependencies.

deb http://ftp.de.debian.org/debian/ oldstable main

Now update the package repository database and install WineH! development branch as shown.

$ sudo apt-get update
$ sudo apt-get install winehq-devel

For other Linux distributions, the installation instructions can be found at https://www.winehq.org/download.



dpkg --add-architecture i386
apt-get update
apt-get install wine32

Even if the second command gives you an error, try again. For example couldn't find the repository. Just try again and again and check your connection.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .