0

We would like to serve ASP.NET Webforms content on Ubuntu 16.04 from 2 different root directories using one XSP4 child process.

In /etc/mono-server4, I created debian.webapp specifying root directory /var/www/firstaspnet and seconddebian.webapp specifying root directory /var/www/secondaspnet. I thought that would be sufficient . Yet I get this runtime exception:

 System.Web.HttpException
    The resource cannot be found.

    Description: HTTP 404.The resource you are looking for (or one of its dependencies) could have been removed, had its name changed, or is temporarily unavailable. Please review the following URL and make sure that it is spelled correctly.

    Details: Requested URL: /hello.aspx
    Exception stack trace:
      at System.Web.Compilation.BuildManager.AssertVirtualPathExists (System.Web.VirtualPath virtualPath) <0x40e88650 + 0x00197> in <filename unknown>:0 
      at System.Web.Compilation.BuildManager.Build (System.Web.VirtualPath vp) <0x40e883f0 + 0x00033> in <filename unknown>:0 
      at System.Web.Compilation.BuildManager.GetCompiledType (System.Web.VirtualPath virtualPath) <0x40e880a0 + 0x00093> in <filename unknown>:0 
      at System.Web.Compilation.BuildManager.CreateInstanceFromVirtualPath (System.Web.VirtualPath virtualPath, System.Type requiredBaseType) <0x40e87f50 + 0x00033> in <filename unknown>:0 
      at System.Web.UI.PageParser.GetCompiledPageInstance (System.String virtualPath, System.String inputFile, System.Web.HttpContext context) <0x40e87bb0 + 0x000bb> in <filename unknown>:0 
      at System.Web.UI.PageHandlerFactory.GetHandler (System.Web.HttpContext context, System.String requestType, System.String url, System.String path) <0x40e87b70 + 0x00027> in <filename unknown>:0 
      at System.Web.HttpApplication.GetHandler (System.Web.HttpContext context, System.String url, Boolean ignoreContextHandler) <0x40e7ccb0 + 0x002de> in <filename unknown>:0 
      at System.Web.HttpApplication.GetHandler (System.Web.HttpContext context, System.String url) <0x40e7cc80 + 0x0001b> in <filename unknown>:0 
      at System.Web.HttpApplication+<Pipeline>c__Iterator1.MoveNext () <0x40e65a50 + 0x02aab> in <filename unknown>:0

I am running only one instance of mod-mono-server4.exe spawned by my systemd apache2.service during system reboot as shown below by ps -ef:

  148:www-data  1090     1  0 16:42 ?        00:00:00 /usr/bin/mono /usr/lib/mono/4.5/mod-mono-server4.exe --filename /tmp/.mod_mono_server4 --nonstop --appconfigdir /etc/mono-server4

Could someone venture a hypothesis about what I am missing or did wrong?

Any help is greatly appreciated.

  • What Ubuntu log file should I look at to diagnose what went wrong? Thank you. – Frank Jun 14 '16 at 1:44
  • What script file does apache2 use to launches the mod-mono-server4.exe process? I was hoping to add additional command line argument such as --port and --debug. – Frank Jun 14 '16 at 1:47
  • web.config specifies where your temporary compilation directory is located. – Frank Jun 14 '16 at 3:11
  • Here are two excellent URLS which I will test at 7:00 A.M. today. codedigest.com/Articles/ASPNET/… msdn.microsoft.com/en-us/library/ms178116.aspx – Frank Jun 14 '16 at 9:32
  • I said something in my original question. Two independent ASP-NET host processes are required rather one. Thank you. – Frank Jun 14 '16 at 18:41

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.