I am trying to boot Fedora 23 that I have just installed on a laptop, replacing Windows. I just can't boot it. I kept the UEFI boot partition but replaced all the other partitions with Linux ones. The problems are:

  1. Fedora is in the list when I run efibootmgr and I can put it first in the boot order, but when I reboot, the firmware ignores the boot order and tries to boot Windows first, and also resets the boot order. I can stop it from trying to boot windows by removing the Windows boot loader, but then it tries to boot the next items on the boot order and skips the installed Fedora (possibly because by that point, I'm guessing, the boot order has already been reset). This is very suspicious.
  2. In the firmware settings, under Settings -> General -> Boot Sequence, Fedora doesn't show up, even though it shows up in efibootmgr. If I try to add it manually, 2 disks show up in the UI, but they seem to both be duplicate copies of the USB stick - they are exactly the same as each other and they contain the same files that are on the USB stick, including one of my personal files that I put on there.
  3. Setting the next boot OS with efibootmgr -n also doesn't work. If I run efibootmgr again immediately after running that command, it shows the changed settings, so it doesn't look like it's failed to write them.

P.S. Because I have removed the Windows boot loader, if I remove the USB stick and reboot, the laptop then goes into Dell SupportAssist mode.

  • Did you install Fedora from an EFI shim aware disk? – eyoung100 Jun 13 '16 at 19:29
  • Sure you do not have two ESPs? Can you get to a UEFI shell prompt? – fpmurphy Jun 14 '16 at 1:54

Seems like a firmware bug. I finally worked around it by:

  1. Deleting the Microsoft directory in /boot/efi/EFI and replacing it with the contents of the Fedora directory (note: this assumes you don't want to dual boot with Windows, which I don't).
  2. Copying the grub .efi file into where the firmware expected to find the Windows boot loader.

Note: The above two steps still didn't make it boot automatically when the USB stick was inserted for some reason, but even when the USB stick was inserted, I could still select Grub by pressing F12 on boot up.

  • There is not normally a Windows directory in the ESP. Typically there is a Microsoft directory and the Microsoft boot loader is located at ../Microsoft/boot/bootmgfw.efi. If you want GRUB2 to be your only bootloader, install it as BOOTX64.EFI (assuming you have an IA64 platform) – fpmurphy Jun 14 '16 at 9:50

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.