3

The PackageKit Project dialog keeps popping up to prompt for the root password on my Debian Jessie desktop, apparently assuming that the logged in account has root permissions or knows the root password

Is there someway to disable it in the desktop settings?

7

Are you using KDE? I had this problem the other day, and systemctl stop/disable packagekit didn't help at all.

Here's the prompt:

Root password prompt

In this example, polkit.subject-pid is PID 2201, which is:

username     2201  0.0  0.1 1354816 24440 ?       Sl   Oct27   2:46 kded5 [kdeinit5]

Which suggests that KDE might be doing something. On my system, KDE doesn't have package management settings in the system settings tool, but opening apper's settings menu I found this:

Apper configuration dialog

Setting this to Never took care of the problem for me.


Update: systemctl mask packagekit works as well. See for example http://0pointer.de/blog/projects/three-levels-of-off, which describes the difference between systemctl stop, disable, and mask. mask makes services completely unstartable until they are unmasked again.

0

There are distributions, where neither of this works ...
but one alternatively can disable the refresh manually:

su
cat <<EOF >> /etc/yum/pluginconf.d/refresh-packagekit.conf
[main]
enabled=0
EOF
service packagekit restart

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.