The LibreOffice has this weird dark to white gradient in the toolbar. I don't have any custom LO theme (maybe an icon theme). I do have a dark Plasma theme, but none of the KDE apps have any gradient issues. (I'm not really sure if LO is a Qt or GTK). I've tried searching through LO options, messing around with colour settings, but couldn't find anything that would help.


I'm not sure if it's related, but those cell headers have this light highlight that's also distracting, but I also couldn't find anywhere to change that.

$ pacman -Qi libreoffice-fresh | grep Version
Version         : 5.1.3-1
  • @DKBose are you suggesting it's cross-posted? It seems like a (slightly) different issue.
    – terdon
    Jun 13, 2016 at 15:39
  • Totally different. Was just an FYI.
    – DK Bose
    Jun 13, 2016 at 15:42
  • @DKBose oh, OK, I was asking 'cause it is actually the same OP.
    – terdon
    Jun 13, 2016 at 16:00
  • yeah, that post is mine too. different issues. different posts. Just the other one was specifically on lubuntu, that's why it's on askubuntu. This one is on my arch. Jun 13, 2016 at 22:17

2 Answers 2


It looks like this is an issue with the current Qt / Plasma widget set for Libreoffice (hope they sort it out soon). In the meantime, you can manually force LibreOffice to use a different toolkit using the SAL_USE_VCLPLUGIN environment variable.

For example: SAL_USE_VCLPLUGIN=gtk localc will launch LibreOffice Calc using GTK instead (gen and kde4 are also valid options).

This can also be set on a more permanent basis by editing /etc/profile.d/libreoffice-fresh.sh

  • But this forces LO into gtk, which I'd like to avoid, because it has an abysmal file-choosing dialog. Nov 29, 2016 at 15:12
  • Does SAL_USE_VCLPLUGIN=gen or SAL_USE_VCLPLUGIN=kde4 provide a better file choice dialog? They're also available as alternatives. Dec 5, 2016 at 1:57

According to https://forum.antergos.com/topic/4006/libreoffice-writer-has-awful-gradient-in-toolbar-backgrounds/2

You need to create, add, or uncomment this line in your /etc/profile.d/libreoffice-fresh.sh file:



You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .