Fedora is my first Linux-based OS I've ever installed and everything seemed to be going well until I tried to log in. I enter my credentials and the login disappears leaving only the background image and the cursor. I've reinstalled 3 times and still have the same problem. Any suggestions? I've already looked at Fedora 19 freezes after login, but I do not understand any of it.

  • Are you able to successfully login via a virtual terminal and get to a shell prompt? Use Ctrl-Alt-F1 to get to a virtual terminal.
    – fpmurphy
    Jun 10, 2016 at 23:56
  • I login through the terminal and everything seems fine, what's next? Jun 11, 2016 at 23:03

2 Answers 2


I had a similar issue with 24. Very strange. I rebooted, clicked on 'not listed' and entered my root user login. That got me into the desktop! Then I went to settings/users, unlocked it, and enabled autologin for my main account. Just to be safe I added myself as 2 different new accounts, 1 as administrator. But they turned out to be unnecessary (I think), because thereafter booting brought me straight to the desktop.


This used to happen to me as well, my issue was graphics drivers, the only thing that solved it for me was to install the Nvidia drivers.

That stopped the freezing and even speeded up the login process.

  • 1
    How did you install the nvidia drivers? Without bwing on the desktop Jun 24, 2016 at 14:00

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .