3

I just upgraded Iceweasel to Firefox 45.2.0 (with apt-get dist-upgrade) on my computer which runs Debian 8 (Stable). When I switch to fullscreen the window title bar doesn't go away. I didn't have this problem in Iceweasel. Any clues? I use the window manager Blackbox and fullscreen works correctly with other applications.

0

It has been two years since the question was asked, however, recently I run into exactly same issue (running Firefox full screen on Blackbox).

This Github issue explains why it happens.

In short: It is not a Firefox issue. It is a Blackbox issue. It can be fixed by applying patch given in the linked Github issue. Or, if you are not comfortable with changing source code and recompiling the Blackbox, the workaround is to:

  1. Maximize the Firefox window first.
  2. Enable fullscreen mode on Firefox.

In this case the title bar disappears.

Disclaimer: I created the linked issue and the patch.

-1

While in full screen mode, if you right-click at the very top of the screen, is there a checkmark in front of "Hide Toolbars"? If not, go ahead and click that to turn it back on. The corresponding preference in about:config is browser.fullscreen.autohide (default value is true).

  • Thanks for your reply. However, the problem is not that the tool bar doesn't go away; it's the window title bar (provided by the window manager) that keeps showing. – August Karlstrom Jun 13 '16 at 7:19

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.