4

Trying to get Kali Linux Rolling 2016.1 installed on an out-of-the-box brand new Dell XPS 13 Developer Edition (meaning it came with Ubuntu 14.04 LTS installed on it).

I'm installing it with no connection to the internet, and using a PNY USB that I know has worked in the past (about a week ago) with a freshly downloaded and checked Kali 2016.1 iso.

I have been installing this via Legacy boot.

The installation itself goes smoothly, and I am given no errors on both a Graphical Install and the regular Install.

The only potential hiccup is a prompt informing me that I need to manually install some non-free firmware for my hardware (specifically iwlwifi-8000C-17.ucode), which I decline at the time since I only have 1 USB drive to load from at the moment (I assume I can load that firmware post-installation?).

The Live boot works perfectly and all hardware components function normally.

For some reason, after a seemingly successful installation, I receive the errors below (I apologize for the large images).

The first errors appear upon entering the correct login info, and occur every time I try to login, removing me back to the login prompt after about 10 seconds.

The second errors occur a few minutes after the initial log in, but not subsequent ones.

Prior to getting these errors, I can see the red "[FAILED]" markers during boot, but they're gone way too quickly for me to see what they are referencing. Although one of them is definitely along the lines of "failed to start Network Manager".


Tried installing using the UEFI boot. Disabled Legacy boot, added a new UEFI option by pointing it at the syslinux.efi in the BOOT folder on the Kai Live USB.

Installation completed the same as before, but now the laptop tells me there are no bootable devices available.

Boot Option is as follows:

Name: kali
File System List: HD(1, 0, 0)
File Name: \EFI\kali\grubx64.efi

After enabling Legacy Boot again, and booting into the Live Kali USB, gparted can't see the internal storage at all.

It can only see the USB on /dev/sda, but doesn't see the Internal drive which I know is located at /dev/nvme0n1

But I can see the drive and all of it's partitions from fdisk -l


Tried to install it again in Legacy boot, this time using my wifi and a network mirror. Still can not log in, and entering the correct info flashes the screen and then displays the login prompt again.

But, at least it resized the text to fit my resolution this time.


About a minute or so after trying to login a few times, it just output 10 lines of errors:

[ (some number) blk_update_request: I/O error, dev nvme0n1, sector (some number)

Booted up one of the other still untouched XPS 13's with Ubuntu 14.04 LTS still installed. Installed and ran gparted, and even it can only see the USB, it can't see it's own internal drive on /dev/nvme0n1.

I have no idea what to make of this. Going to create a Ubuntu install USB and try to install it on the first laptop, because I really doubt this is an actual drive failure (or maybe I'm just in denial and don't want to fill out the return forms at work on a Friday...). So I'll see if these laptops have some weird thing where Kali just doesn't work on them. I'll try Debian next if the Ubuntu install doesn't crash and burn horribly.


Reinstalled Ubuntu 14.04 LTS on the first laptop to check if it was really drive failure or just Kali being Kali, and it gave me a fatal error when trying to install GRUB.

Found a similar error on the ubuntu Stack Exchange here, and found out that for some reason using the installer's "use the whole disk" option in ubuntu breaks it on SSD drives that list as nvme0n1 instead of sda, sdb, etc... and instead I had to partition the drive and point grub to it manually in the Ubuntu installer. After doing that it installed with no errors and I'm currently typing this from the machine.

I'm now convinced it's an issue with the drive path used in the Kali and Ubuntu (and probably Debian while we're at it) installers, instead of a physical issue.

Going to try and reinstall Kali again from Legacy boot, and this time try to do the equivalent of what I just did in the Ubuntu installer.


Manually partitioning the during installation made the installer hang at creating the first partition, will reattempt on Monday when I get back to the office.


Manually partitioned the drive, with a primary and an extended (logical) for / and swap respectively, using the live Kali USB and pointed the installed at it. Installed without errors, but still getting the same errors while booting after GRUB.

I'm able to log in, but this install looks 100% broken. /home is empty, getting this error a bunch now too:

dhclient [14559]: segfault at (number) up (number) sp (number) error 7 in dhclient[(number)+72000]

enter image description here

enter image description here

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.